Cython -la doesn't work #2709

Closed
piti118 opened this Issue Dec 20, 2012 · 2 comments

Comments

Projects
None yet
3 participants
Contributor

piti118 commented Dec 20, 2012

It's parsed as -l instead.

    @magic_arguments.argument(
        '-la', '--link-args', action='append', default=[],
        help="Extra flags to pass to linker via the `extra_link_args` "
             "Extension flag (can be specified  multiple times)."
    )
    @magic_arguments.argument(
        '-l', '--lib', action='append', default=[],
        help="Add a library to link the extension against (can be specified "
             "multiple times)."
    )
Contributor

bfroehle commented Dec 20, 2012

Can we just get rid of -la and use --link-args always? Or would you suggest a different short argument?

Contributor

piti118 commented Dec 20, 2012

I use link-args.. lets see
a b c d e f g h i j k l m n o p q r s t u v w x y z...
No good letter. Just get rid of them I think.

minrk closed this in 1cba5f9 Jan 19, 2013

@minrk minrk added a commit to minrk/ipython that referenced this issue Jan 26, 2013

@minrk minrk remove nonfunctional `-la` short arg in cython magic
short flags only allow one letter, so `-la` is the same as `-l`,
which is already taken.

closes #2709
a62a49a

@mattvonrocketstein mattvonrocketstein pushed a commit to mattvonrocketstein/ipython that referenced this issue Nov 3, 2014

@minrk minrk remove nonfunctional `-la` short arg in cython magic
short flags only allow one letter, so `-la` is the same as `-l`,
which is already taken.

closes #2709
fdef1e3
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment