ipython-qtconsole: pyzmq Version Comparison #874

pcarey opened this Issue Oct 14, 2011 · 1 comment

2 participants


I've installed ipython-0.11 with pyzmq 2.1.10. I tried to run ipython-qtconsole, and received the error message:

Traceback (most recent call last):
File "/usr/local/python/2.7.1/bin/ipython-qtconsole", line 8, in
load_entry_point('ipython==0.11', 'gui_scripts', 'ipython-qtconsole')()
File "build/bdist.linux-i686/egg/pkg_resources.py", line 318, in load_entry_point
"""Locate distribution dist_spec and run its script_name script"""
File "build/bdist.linux-i686/egg/pkg_resources.py", line 2221, in load_entry_point
def get_metadata(self,name):
File "build/bdist.linux-i686/egg/pkg_resources.py", line 1954, in load
File "/usr/local/python/2.7.1/lib/python2.7/site-packages/IPython/frontend/qt/console/qtconsoleapp.py", line 36, in
from IPython.frontend.qt.kernelmanager import QtKernelManager
File "/usr/local/python/2.7.1/lib/python2.7/site-packages/IPython/frontend/qt/kernelmanager.py", line 9, in
from IPython.zmq.kernelmanager import KernelManager, SubSocketChannel, \
File "/usr/local/python/2.7.1/lib/python2.7/site-packages/IPython/zmq/__init_
.py", line 25, in
minimum_pyzmq_version, pyzmq_version))
ImportError: IPython.zmq requires pyzmq >= 2.1.4, but you have 2.1.10

IPython member

Thanks. It's already fixed in trunk. In the meantime, you'll need to force the installation of pyzmq 2.1.9, or comment out these lines in IPython/zmq/__init__.py:

if pyzmq_version < minimum_pyzmq_version:
   raise ImportError("IPython.zmq requires pyzmq >= %s, but you have %s"%(
                   minimum_pyzmq_version, pyzmq_version))
@takluyver takluyver closed this Oct 14, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment