Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

don't assume cursor.selectedText() is a string #725

Merged
merged 1 commit into from

5 participants

@minrk
Owner

Apparently in some cases cursor.selectedText() can return None instead of an empty
string (Scientific Linux 6.0 being only reported case). Relax logic using this method,
so string methods are only called when the string is not empty.

Should fix #724

@fperez
Owner

+1, correct logic, thanks for fixing this. Merge away.

Since your message doesn't say 'closes gh-724' you may need to do it manually, I don't know if gh will identify 'fix #724' as well.

@minrk
Owner

the actual commit message does have the 'closes' text. The commit parser is pretty greedy, though - I have had it auto-close Issues I only mentioned.

@fperez
Owner

Ah, got it. Good to know, thanks.

@epatters

It doesn't seem appropriate to merge this. Please see the discussion in #724, in which the user reports further problems.

@minrk
Owner

Yes, either we need to place a bound on our PyQt version dependency, or fix every string check to allow for None.

@fperez
Owner
@minrk
Owner

Fair enough, but what version? Do we just guess that 4.7.0 resolves the issue? I see no evidence of this change in the pyqt docs, and I'm certainly not going to build a bunch of PyQt versions to find out.

Should we make the PySide import version check as well, since early dev versions are known to not work?

@fperez
Owner
@minrk
Owner

There's also the hilarious fact that I have no idea how to find out the PyQt version from Python...

@epatters

@fperez I don't know which versions of PyQt have this bug, sorry. It may be worth posting to their mailing list. For PySide, I think that versions 1.0.3+ work with IPython.

@minrk It's not very well advertised, but this works:

from PyQt4 import QtCore
QtCore.QT_VERSION, QtCore.QT_VERSION_STR  # Qt version info
QtCore.PYQT_VERSION, Qtcore.PYQT_VERSION_STR # Binding version info
@minrk minrk version check Qt bindings in external.qt
require PySide >= 1.0.3 or PyQt4 >= 4.7

closes gh-724
be3e7ed
@minrk
Owner

Thanks, @epatters, it would have taken me a long time to find that.

I just redid this branch, so that it only adds version checks to external.qt, so the frontend won't try to start with PyQt < 4.7 or PySide < 1.0.3.

@epatters

Well, this looks good to me. Thanks, Min.

@minrk minrk merged commit 6cf495c into ipython:master
@ellisonbg ellisonbg referenced this pull request from a commit
Commit has since been removed from the repository and is no longer available.
@takluyver

@rajeeja: Hi, welcome to IPython. The best thing for this sort of problem is to join the ipython-user mailing list and ask for help there - that way more people will see your question. http://mail.scipy.org/mailman/listinfo/ipython-user

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 24, 2011
  1. @minrk

    version check Qt bindings in external.qt

    minrk authored
    require PySide >= 1.0.3 or PyQt4 >= 4.7
    
    closes gh-724
This page is out of date. Refresh to see the latest.
Showing with 13 additions and 1 deletion.
  1. +13 −1 IPython/external/qt.py
View
14 IPython/external/qt.py
@@ -25,14 +25,21 @@ def prepare_pyqt4():
if QT_API is None:
try:
import PySide
+ if PySide.__version__ < '1.0.3':
+ # old PySide, fallback on PyQt
+ raise ImportError
QT_API = QT_API_PYSIDE
except ImportError:
try:
prepare_pyqt4()
import PyQt4
+ from PyQt4 import QtCore
+ if QtCore.PYQT_VERSION_STR < '4.7':
+ # PyQt 4.6 has issues with null strings returning as None
+ raise ImportError
QT_API = QT_API_PYQT
except ImportError:
- raise ImportError('Cannot import PySide or PyQt4')
+ raise ImportError('Cannot import PySide >= 1.0.3 or PyQt4 >= 4.7')
elif QT_API == QT_API_PYQT:
# Note: This must be called *before* PyQt4 is imported.
@@ -41,12 +48,17 @@ def prepare_pyqt4():
# Now peform the imports.
if QT_API == QT_API_PYQT:
from PyQt4 import QtCore, QtGui, QtSvg
+ if QtCore.PYQT_VERSION_STR < '4.7':
+ raise ImportError("IPython requires PyQt4 >= 4.7, found %s"%QtCore.PYQT_VERSION_STR)
# Alias PyQt-specific functions for PySide compatibility.
QtCore.Signal = QtCore.pyqtSignal
QtCore.Slot = QtCore.pyqtSlot
elif QT_API == QT_API_PYSIDE:
+ import PySide
+ if PySide.__version__ < '1.0.3':
+ raise ImportError("IPython requires PySide >= 1.0.3, found %s"%PySide.__version__)
from PySide import QtCore, QtGui, QtSvg
else:
Something went wrong with that request. Please try again.