Skip to content
Permalink
Browse files

update p2diff so it will compile against Luna, Tycho 0.20, and JUnit …

…4.11
  • Loading branch information...
nickboldt committed Apr 4, 2014
1 parent e1d6a9a commit ba30a063c6802bf432692752f77c73ec16bdba7e
@@ -25,8 +25,8 @@
<plugin id="org.eclipse.core.net"/>
<plugin id="org.eclipse.core.runtime"/>
<plugin id="org.eclipse.ecf.provider.filetransfer"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient.ssl" fragment="true"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient4"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient4.ssl" fragment="true"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.ssl" fragment="true"/>
<plugin id="org.eclipse.equinox.ds"/>
<plugin id="org.eclipse.equinox.p2.core"/>
@@ -14,4 +14,37 @@
<artifactId>org.eclipse.equinox.p2.example.p2diff.packaging</artifactId>
<packaging>eclipse-repository</packaging>

<build>
<plugins>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-publisher-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<publishArtifacts>true</publishArtifacts>
</configuration>
</plugin>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-repository-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<includeAllDependencies>true</includeAllDependencies>
</configuration>
</plugin>
<plugin>
<groupId>org.eclipse.tycho</groupId>
<artifactId>tycho-p2-director-plugin</artifactId>
<version>${tycho-version}</version>
<configuration>
<products>
<product>
<id>org.eclipse.equinox.p2.example.p2diff.product</id>
</product>
</products>
</configuration>
</plugin>
</plugins>
</build>

</project>
@@ -10,14 +10,14 @@
<packaging>pom</packaging>

<properties>
<tycho-version>0.15.0</tycho-version>
<tycho-version>0.20.0</tycho-version>
</properties>

<repositories>
<repository>
<id>platformRepo-38</id>
<id>luna-M6</id>
<layout>p2</layout>
<url>http://download.eclipse.org/eclipse/updates/3.8</url>
<url>http://download.jboss.org/jbosstools/updates/requirements/luna/201403140900-M6/</url>
</repository>
</repositories>

@@ -17,7 +17,7 @@
</modules>

<name>Releng Project</name>
<artifactId>or.geclipse.equinox.p2.example.p2diff.releng</artifactId>
<artifactId>org.eclipse.equinox.p2.example.p2diff.releng</artifactId>
<packaging>pom</packaging>

</project>
@@ -5,6 +5,6 @@ Bundle-SymbolicName: org.eclipse.equinox.p2.example.p2diff.tests
Bundle-Version: 1.0.0.qualifier
Fragment-Host: org.eclipse.equinox.p2.example.p2diff;bundle-version="1.0.0"
Require-Bundle: org.eclipse.core.runtime,
org.junit4;bundle-version="4.8.1"
org.junit;bundle-version="4.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ActivationPolicy: lazy

0 comments on commit ba30a06

Please sign in to comment.
You can’t perform that action at this time.