Grid Security Infrastructure (GSI) authentication plugin for iRODS
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
gsi
packaging
.gitignore
CMakeLists.txt
LICENSE
README
irods_consortium_continuous_integration_build_hook.py
irods_consortium_continuous_integration_test_hook.py

README

iRODS GSI Auth Plugin
---------------------

To build the GSI Auth Plugin, you will need to have:

 - the iRODS Development Tools (irods-dev and irods-runtime) installed for your platform
     http://irods.org/download

 - globus-proxy-utils installed for your platform

Note:

Once installed, the `X509_USER_CERT` and `X509_USER_KEY` are necessary to be set for the service EVEN IF the default paths are used.
(i.e. /etc/grid-security/service/servicekey(cert).pem)