Permalink
Browse files

Got rid of jeweler.

  • Loading branch information...
1 parent 2e9514e commit fbfaeddefbc1347bd0dd7b785143664aa905dc59 @treeder treeder committed Aug 22, 2012
Showing with 26 additions and 74 deletions.
  1. +4 −0 Gemfile
  2. +1 −0 README.md
  3. +0 −23 Rakefile
  4. +20 −46 iron_core.gemspec
  5. +1 −5 lib/iron_core/version.rb
View
@@ -1,5 +1,9 @@
source 'http://rubygems.org'
+
+gemspec
+
+
gem 'rest', '>= 2.0.3'
group :development do
View
@@ -0,0 +1 @@
+Common library among www.iron.io Ruby clients.
View
@@ -1,25 +1,2 @@
require File.expand_path('../lib/3rdparty/facets/require_relative', __FILE__)
-require 'rubygems'
-require 'bundler'
-require 'jeweler2'
-
-Jeweler::Tasks.new do |gem|
- begin
- Bundler.setup(:default, :development)
- rescue Bundler::BundlerError => e
- $stderr.puts e.message
- $stderr.puts "Run `bundle install` to install missing gems"
- exit e.status_code
- end
-
- gem.name = "iron_core"
- gem.homepage = "https://github.com/iron-io/iron_core_ruby"
- gem.description = %Q{Core library for Iron products}
- gem.summary = %Q{Core library for Iron products}
- gem.email = "info@iron.io"
- gem.authors = ["Andrew Kirilenko", "Iron.io, Inc"]
- gem.files.exclude('.document', 'Gemfile', 'Gemfile.lock', 'Rakefile', 'iron_core.gemspec')
-end
-
-Jeweler::RubygemsDotOrgTasks.new
View
@@ -1,51 +1,25 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
-# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/iron_core/version', __FILE__)
-Gem::Specification.new do |s|
- s.name = "iron_core"
- s.version = "0.3.3"
+Gem::Specification.new do |gem|
+ gem.authors = ["Andrew Kirilenko", "Iron.io, Inc"]
+ gem.email = ["info@iron.io"]
+ gem.description = "Core library for Iron products"
+ gem.summary = "Core library for Iron products"
+ gem.homepage = "https://github.com/iron-io/iron_core_ruby"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Andrew Kirilenko", "Iron.io, Inc"]
- s.date = "2012-07-20"
- s.description = "Core library for Iron products"
- s.email = "info@iron.io"
- s.extra_rdoc_files = [
- "LICENSE"
- ]
- s.files = [
- "LICENSE",
- "VERSION",
- "lib/iron_core.rb",
- "lib/iron_core/client.rb",
- "lib/iron_core/error.rb",
- "lib/iron_core/logger.rb",
- "lib/iron_core/response_error.rb",
- "lib/iron_core/version.rb"
- ]
- s.homepage = "https://github.com/iron-io/iron_core_ruby"
- s.require_paths = ["lib"]
- s.rubygems_version = "1.8.24"
- s.summary = "Core library for Iron products"
+ gem.files = `git ls-files`.split($\)
+ gem.executables = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
+ gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
+ gem.name = "iron_core"
+ gem.require_paths = ["lib"]
+ gem.version = IronCore::VERSION
- if s.respond_to? :specification_version then
- s.specification_version = 3
+ gem.required_rubygems_version = ">= 1.3.6"
+ gem.required_ruby_version = Gem::Requirement.new(">= 1.9")
+ gem.add_runtime_dependency "rest", ">= 2.0.3"
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<rest>, [">= 2.0.0"])
- s.add_development_dependency(%q<rake>, [">= 0"])
- s.add_development_dependency(%q<jeweler2>, [">= 0"])
- else
- s.add_dependency(%q<rest>, [">= 2.0.0"])
- s.add_dependency(%q<rake>, [">= 0"])
- s.add_dependency(%q<jeweler2>, [">= 0"])
- end
- else
- s.add_dependency(%q<rest>, [">= 2.0.0"])
- s.add_dependency(%q<rake>, [">= 0"])
- s.add_dependency(%q<jeweler2>, [">= 0"])
- end
-end
+ gem.add_development_dependency "test-unit"
+ gem.add_development_dependency "minitest"
+ gem.add_development_dependency "rake"
+end
View
@@ -1,7 +1,3 @@
module IronCore
- @@version = nil
-
- def self.version
- @@version ||= File.read(File.dirname(__FILE__) + '/../../VERSION').strip
- end
+ VERSION = "0.4.0"
end

0 comments on commit fbfaedd

Please sign in to comment.