Skip to content
Browse files

Working on getting tests to run with bundler.

  • Loading branch information...
1 parent 8c23a91 commit 1c7929bdc03549d67bbb60725e4bbd7d90e45392 @treeder treeder committed Jan 19, 2012
Showing with 40 additions and 21 deletions.
  1. +3 −1 {test → }/Gemfile
  2. +34 −14 {test → }/Gemfile.lock
  3. +3 −0 Rakefile
  4. +0 −6 test/workers/big_gems_worker.rb
View
4 test/Gemfile → Gemfile
@@ -2,7 +2,9 @@
source 'http://rubygems.org'
+gem 'rack', '< 1.4'
gem 'test-unit'
+gem 'jeweler2'
gem 'zip'
gem 'rest'
@@ -13,4 +15,4 @@ gem 'mongoid_i18n'
gem 'signature'
gem 'pusher'
gem 'carrierwave'
-
+gem 'aws-s3'
View
48 test/Gemfile.lock → Gemfile.lock
@@ -12,6 +12,10 @@ GEM
http_connection
uuidtools
xml-simple
+ aws-s3 (0.6.2)
+ builder
+ mime-types
+ xml-simple
bson (1.5.2)
builder (3.0.0)
carrierwave (0.5.8)
@@ -23,36 +27,45 @@ GEM
eventmachine
faraday
faraday
+ cookiejar (0.3.0)
+ domain_name (0.5.2)
+ unf (~> 0.0.3)
dropbox (1.2.3)
json (>= 1.2.0)
mechanize (>= 1.0.0)
multipart-post (>= 1.0)
oauth (>= 0.3.6)
- em-http-request (1.0.0)
+ em-http-request (1.0.1)
addressable (>= 2.2.3)
+ cookiejar
em-socksify
- eventmachine (>= 1.0.0.beta.3)
- http_parser.rb (>= 0.5.2)
+ eventmachine (>= 1.0.0.beta.4)
+ http_parser.rb (>= 0.5.3)
em-socksify (0.1.0)
eventmachine
eventmachine (1.0.0.beta.4)
faraday (0.7.5)
addressable (~> 2.2.6)
multipart-post (~> 1.1.3)
- rack (< 2, >= 1.1.0)
+ rack (>= 1.1.0, < 2)
+ git (1.2.5)
http_connection (1.4.1)
http_parser.rb (0.5.3)
i18n (0.6.0)
- json (1.6.3)
- mechanize (2.0.1)
- net-http-digest_auth (>= 1.1.1, ~> 1.1)
- net-http-persistent (~> 1.8)
+ jeweler2 (2.0.9)
+ git (>= 1.2.5)
+ json (1.6.5)
+ mechanize (2.1)
+ domain_name (~> 0.5, >= 0.5.1)
+ net-http-digest_auth (~> 1.1, >= 1.1.1)
+ net-http-persistent (~> 2.3, >= 2.3.2)
nokogiri (~> 1.4)
- webrobots (>= 0.0.9, ~> 0.0)
+ ntlm-http (~> 0.1, >= 0.1.1)
+ webrobots (~> 0.0, >= 0.0.9)
mime-types (1.17.2)
mongo (1.5.2)
bson (= 1.5.2)
- mongoid (2.3.4)
+ mongoid (2.4.1)
activemodel (~> 3.1)
mongo (~> 1.3)
tzinfo (~> 0.3.22)
@@ -61,15 +74,16 @@ GEM
multi_json (1.0.4)
multipart-post (1.1.4)
net-http-digest_auth (1.2)
- net-http-persistent (1.9)
+ net-http-persistent (2.3.3)
nokogiri (1.5.0)
+ ntlm-http (0.1.1)
oauth (0.4.5)
pusher (0.8.5)
multi_json (~> 1.0)
ruby-hmac (~> 0.4.0)
signature (~> 0.1.2)
- rack (1.3.5)
- rest (0.0.1)
+ rack (1.3.6)
+ rest (0.1.0)
rest-client
rest-client
rest-client (1.6.7)
@@ -80,8 +94,11 @@ GEM
simple_record (2.2.0)
aws
concur
- test-unit (2.4.3)
+ test-unit (2.4.5)
tzinfo (0.3.31)
+ unf (0.0.4)
+ unf_ext
+ unf_ext (0.0.4)
uuidtools (2.1.2)
webrobots (0.0.12)
nokogiri (>= 1.4.4)
@@ -93,10 +110,13 @@ PLATFORMS
DEPENDENCIES
activesupport
+ aws-s3
carrierwave
dropbox (= 1.2.3)
+ jeweler2
mongoid_i18n
pusher
+ rack (< 1.4)
rest
signature
simple_record
View
3 Rakefile
@@ -1,3 +1,6 @@
+require "rubygems"
+require "bundler/setup"
+
require 'rake/dsl_definition' # temporary I think?
require 'rake/testtask'
require 'jeweler2'
View
6 test/workers/big_gems_worker.rb
@@ -4,19 +4,13 @@
class BigGemsWorker < IronWorker::Base
merge_gem 'activesupport', {:version => '3.1.3', :require=>'active_support/core_ext'}
- #merge_gem 'railties', {:version => '3.1.3', :require => 'rails'}
require 'mysql2'
- merge_gem 'activemodel', {:version => '3.1.3', :require=>'active_model'}
- merge_gem 'activemodel', {:version => '3.1.3', :require=>'active_model/secure_password'}
-
merge_gem 'activerecord', {:version => '3.1.3', :require=>'active_record'}
merge_gem 'actionmailer', {:version => '3.1.3', :require=>'action_mailer'}
- merge_gem 'actionpack', {:version => '3.1.3', :require => 'action_pack'}
require 'RMagick'
merge_gem 'timecop'
-
merge_gem 'carrierwave', {:version => '0.5.8', :require => ['carrierwave', 'carrierwave/orm/activerecord']}
merge_gem 'fog'
#merge_gem 'friendly_id', {:version => '4.0.0.beta14'}

0 comments on commit 1c7929b

Please sign in to comment.
Something went wrong with that request. Please try again.