Skip to content
This repository
Newer
Older
100644 75 lines (71 sloc) 2.75 kb
28bfccd7 » iced
2012-02-21 Gemspec.
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = "iron_worker_ng"
fdbfed42 » iced
2012-03-27 Regenerate gemspec for version 0.1.11
8 s.version = "0.1.11"
28bfccd7 » iced
2012-02-21 Gemspec.
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
587f3839 » iced
2012-02-23 Switched to 2-clause BSD license.
11 s.authors = ["Andrew Kirilenko", "Iron.io, Inc"]
c89d23d1 » iced
2012-03-27 Regenerate gemspec for version 0.1.9
12 s.date = "2012-03-27"
587f3839 » iced
2012-02-23 Switched to 2-clause BSD license.
13 s.description = "New generation ruby client for IronWorker"
14 s.email = "info@iron.io"
28bfccd7 » iced
2012-02-21 Gemspec.
15 s.executables = ["iron_worker_ng"]
16 s.extra_rdoc_files = [
0336a460 » iced
2012-02-22 Installing only needed files.
17 "LICENSE",
28bfccd7 » iced
2012-02-21 Gemspec.
18 "README.md"
19 ]
20 s.files = [
0336a460 » iced
2012-02-22 Installing only needed files.
21 "LICENSE",
28bfccd7 » iced
2012-02-21 Gemspec.
22 "README.md",
23 "VERSION",
24 "bin/iron_worker_ng",
25 "lib/iron_worker_ng.rb",
26 "lib/iron_worker_ng/api_client.rb",
27 "lib/iron_worker_ng/api_client_error.rb",
28 "lib/iron_worker_ng/client.rb",
b85143e3 » iced
2012-02-21 Regenerating gemspec.
29 "lib/iron_worker_ng/code/base.rb",
30 "lib/iron_worker_ng/code/java.rb",
31 "lib/iron_worker_ng/code/node.rb",
32 "lib/iron_worker_ng/code/ruby.rb",
28bfccd7 » iced
2012-02-21 Gemspec.
33 "lib/iron_worker_ng/feature/base.rb",
34 "lib/iron_worker_ng/feature/common/merge_dir.rb",
35 "lib/iron_worker_ng/feature/common/merge_file.rb",
36 "lib/iron_worker_ng/feature/java/merge_jar.rb",
37 "lib/iron_worker_ng/feature/java/merge_worker.rb",
38 "lib/iron_worker_ng/feature/node/merge_worker.rb",
39 "lib/iron_worker_ng/feature/ruby/merge_gem.rb",
b85143e3 » iced
2012-02-21 Regenerating gemspec.
40 "lib/iron_worker_ng/feature/ruby/merge_gemfile.rb",
28bfccd7 » iced
2012-02-21 Gemspec.
41 "lib/iron_worker_ng/feature/ruby/merge_worker.rb",
0336a460 » iced
2012-02-22 Installing only needed files.
42 "lib/iron_worker_ng/version.rb"
28bfccd7 » iced
2012-02-21 Gemspec.
43 ]
c89d23d1 » iced
2012-03-27 Regenerate gemspec for version 0.1.9
44 s.homepage = "https://github.com/iron-io/iron_worker_ruby_ng"
28bfccd7 » iced
2012-02-21 Gemspec.
45 s.require_paths = ["lib"]
00b6c7bc » iced
2012-03-21 Accessors for API, no useless . in zip and version bump.
46 s.rubygems_version = "1.8.19"
587f3839 » iced
2012-02-23 Switched to 2-clause BSD license.
47 s.summary = "New generation ruby client for IronWorker"
28bfccd7 » iced
2012-02-21 Gemspec.
48
49 if s.respond_to? :specification_version then
50 s.specification_version = 3
51
52 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
53 s.add_runtime_dependency(%q<zip>, [">= 0"])
54 s.add_runtime_dependency(%q<rest-client>, [">= 0"])
55 s.add_runtime_dependency(%q<rest>, [">= 0"])
56 s.add_runtime_dependency(%q<json>, [">= 0"])
4596aaf4 » iced
2012-03-09 Bundler dep fixed.
57 s.add_runtime_dependency(%q<bundler>, ["> 1.0.0"])
28bfccd7 » iced
2012-02-21 Gemspec.
58 s.add_development_dependency(%q<jeweler>, ["~> 1.8.3"])
59 else
60 s.add_dependency(%q<zip>, [">= 0"])
61 s.add_dependency(%q<rest-client>, [">= 0"])
62 s.add_dependency(%q<rest>, [">= 0"])
63 s.add_dependency(%q<json>, [">= 0"])
4596aaf4 » iced
2012-03-09 Bundler dep fixed.
64 s.add_dependency(%q<bundler>, ["> 1.0.0"])
28bfccd7 » iced
2012-02-21 Gemspec.
65 s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
66 end
67 else
68 s.add_dependency(%q<zip>, [">= 0"])
69 s.add_dependency(%q<rest-client>, [">= 0"])
70 s.add_dependency(%q<rest>, [">= 0"])
71 s.add_dependency(%q<json>, [">= 0"])
4596aaf4 » iced
2012-03-09 Bundler dep fixed.
72 s.add_dependency(%q<bundler>, ["> 1.0.0"])
28bfccd7 » iced
2012-02-21 Gemspec.
73 s.add_dependency(%q<jeweler>, ["~> 1.8.3"])
74 end
75 end
76
Something went wrong with that request. Please try again.