Skip to content

Error while running iron_worker -v #96

Closed
nasht00 opened this Issue Feb 12, 2014 · 2 comments

2 participants

@nasht00
nasht00 commented Feb 12, 2014

I've installed the CLI on OSX running
gem install iron_worker_ng

Then I ran iron_worker -v and got:
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require': no such file to load -- json (LoadError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
require'
from /Library/Ruby/Gems/1.8/gems/iron_worker_ng-0.15.0/lib/iron_worker_ng/client.rb:2
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
require'
from /Library/Ruby/Gems/1.8/gems/iron_worker_ng-0.15.0/lib/iron_worker_ng.rb:4
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in gem_original_require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
require'
from /Library/Ruby/Gems/1.8/gems/iron_worker_ng-0.15.0/bin/iron_worker:6
from /usr/bin/iron_worker:19:in `load'
from /usr/bin/iron_worker:19

@ysadka
ysadka commented Feb 12, 2014

To run the gem on Ruby 1.8 you must install the json gem as well.

$ gem install json

Iron ruby docs: http://dev.iron.io/worker/languages/ruby/
Iron pub chat: http://get.iron.io/chat

@ysadka ysadka closed this Feb 12, 2014
@nasht00
nasht00 commented Feb 13, 2014

The funny thing is I am running Ruby 2.1, using rbenv ... don't know why it is looking for 1.8

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.