Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 34 lines (27 sloc) 1.28 kB
ef9b703 @sunloverz Fix bugs, add netrc gem dependency
sunloverz authored
1 lib = File.expand_path('../lib', __FILE__)
2 $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
3 require 'rest/version'
3b9d0f2 @treeder Regenerate gemspec for version 0.0.1
treeder authored
4
a2a2f45 @treeder Added typhoeus back in.
treeder authored
5 Gem::Specification.new do |gem|
6 gem.authors = ["Travis Reeder"]
7 gem.email = ["treeder@gmail.com"]
8 gem.description = "Rest client wrapper that chooses best installed client."
9 gem.summary = "Rest client wrapper that chooses best installed client."
10 gem.homepage = "https://github.com/iron-io/rest"
3b9d0f2 @treeder Regenerate gemspec for version 0.0.1
treeder authored
11
a2a2f45 @treeder Added typhoeus back in.
treeder authored
12 gem.files = `git ls-files`.split($\)
13 gem.executables = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
14 gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
15 gem.name = "rest"
16 gem.require_paths = ["lib"]
17 gem.version = Rest::VERSION
3b9d0f2 @treeder Regenerate gemspec for version 0.0.1
treeder authored
18
a2a2f45 @treeder Added typhoeus back in.
treeder authored
19 gem.required_rubygems_version = ">= 1.3.6"
6ac24da @iced Ruby 1.8 compatibility
iced authored
20 gem.required_ruby_version = Gem::Requirement.new(">= 1.8")
c3d7b0d @treeder Updated net-http-persistent version, new nhp release causing issues.
treeder authored
21 gem.add_runtime_dependency "net-http-persistent", ">= 2.9.1"
d0868d7 @treeder Changed netrc from dev dependency to runtime dependency.
treeder authored
22 gem.add_runtime_dependency "netrc"
a2a2f45 @treeder Added typhoeus back in.
treeder authored
23
79d5079 @treeder Made typhoeus an optional dependency.
treeder authored
24 gem.add_development_dependency "typhoeus", ">= 0.5.4"
a2a2f45 @treeder Added typhoeus back in.
treeder authored
25 gem.add_development_dependency "test-unit"
6331f6d @treeder Added excon and made errors consistent.
treeder authored
26 gem.add_development_dependency "minitest"
a2a2f45 @treeder Added typhoeus back in.
treeder authored
27 gem.add_development_dependency "rake"
28 gem.add_development_dependency "uber_config"
6ac24da @iced Ruby 1.8 compatibility
iced authored
29 gem.add_development_dependency "quicky", ">= 0.4.0"
9d5dcf6 @treeder Working on excon and standardizing errors.
treeder authored
30 gem.add_development_dependency "excon"
3b9d0f2 @treeder Regenerate gemspec for version 0.0.1
treeder authored
31
32 end
33
Something went wrong with that request. Please try again.