Skip to content
Permalink
Browse files

Dependency updates.

  • Loading branch information
mxsasha committed Dec 17, 2019
1 parent d3daf05 commit 62f60be877d2eade7d6a7e80fb6b3a84d260d079
Showing with 18 additions and 18 deletions.
  1. +13 −13 requirements.txt
  2. +5 −5 setup.py
@@ -3,38 +3,38 @@
# includes packages needed for deployment.

python-gnupg==0.4.5 # Integration with gpg for key-cert objects
passlib==1.7.1 # Password hashing for CRYPT-PW and MD5-PW
passlib==1.7.2 # Password hashing for CRYPT-PW and MD5-PW
IPy==1.00 # IP address parsing
dataclasses==0.7; python_version < '3.7' # PEP 557 dataclasses for python<3.7
ordered-set==3.1.1 # Ordered sets for simple unique ordered storage
dotted==0.1.8 # Dotted path dictionary resolving for settings
beautifultable==0.8.0 # generating nice-looking ascii tables
PyYAML==5.1.2 # parsing YAML config files
PyYAML==5.2 # parsing YAML config files

# Database connections and management
psycopg2-binary==2.8.4
SQLAlchemy==1.3.10
alembic==1.3.0
SQLAlchemy==1.3.12
alembic==1.3.2
ujson==1.35

# Network handling
twisted==19.7.0
twisted==19.10.0

# Testing and related packages
pytest==5.2.2
pytest==5.3.2
pytest-cov==2.8.1
coverage==4.5.4
coveralls==1.8.2
coverage<5.0
coveralls==1.9.2

# Documentation generation
Sphinx==2.2.1
Sphinx==2.3.0

# Code style and type checks
mypy==0.740
mypy==0.750
flake8==3.7.9
pep8-naming==0.8.2
pep8-naming==0.9.1

# Creating python packages
setuptools==41.6.0
setuptools==42.0.2
wheel==0.33.6
twine==2.0.0
twine==3.1.1
@@ -24,17 +24,17 @@
# but should not include packages used for testing, generating docs
# or packages.
'python-gnupg==0.4.5',
'passlib==1.7.1',
'passlib==1.7.2',
'IPy==1.00',
'ordered-set==3.1.1',
'dotted==0.1.8',
'beautifultable==0.8.0',
'PyYAML==5.1.2',
'PyYAML==5.2',
'psycopg2-binary==2.8.4',
'SQLAlchemy==1.3.10',
'alembic==1.3.0',
'SQLAlchemy==1.3.12',
'alembic==1.3.2',
'ujson==1.35',
'twisted==19.7.0',
'twisted==19.10.0',
],
extras_require={
':python_version < "3.7"': [

0 comments on commit 62f60be

Please sign in to comment.
You can’t perform that action at this time.