New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Netsplits don't show in all windows where users split #809

Closed
nvisser opened this Issue Jan 10, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@nvisser

nvisser commented Jan 10, 2018

The fixes in #465 seem to have caused split users to only show as splitting in certain windows, whereas the expected behavior is to show them in every channel they split from. There appears no such split message at all in some windows. If you experience this same issue please share all the knowledge you have about the situation so this can be fixed.

@ailin-nemui

This comment has been minimized.

Contributor

ailin-nemui commented Jan 10, 2018

here's what I think is going on: when the netsplit is announced in a specific channel (because of a public message to that channel, skipping the 5 second timeout), using filter_channel, it will skip over all the non-matching channels. but before it does that, it will already mark the whole split as printed. oops

@ailin-nemui

This comment has been minimized.

Contributor

ailin-nemui commented Jan 10, 2018

@GinjaNinja32 @dwfreed @nvisser does it not show netJOINS? any observations about that?

@ailin-nemui

This comment has been minimized.

Contributor

ailin-nemui commented Jan 11, 2018

can you try #812

@nvisser nvisser changed the title from Netsplit don't show in all windows where users split to Netsplits don't show in all windows where users split Jan 11, 2018

@nvisser

This comment has been minimized.

nvisser commented Jan 11, 2018

I'm running #812 right now, will update this issue when I can split some servers.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment