Skip to content
Browse files

fix issue #496 package.json/engines.node:">.4",npm:">1.0"

  • Loading branch information...
1 parent e1359c6 commit 43cd1e4ae2052dc777c075288e5eb52671d83953 @isao committed Sep 13, 2012
Showing with 2 additions and 6 deletions.
  1. +2 −6 package.json
View
8 package.json
@@ -44,8 +44,8 @@
"mojito": "bin/mojito"
},
"engines": {
- "node": ">= 0.4.0 < 0.7.0",
- "npm": ">= 1.0.0"
+ "node": ">0.4",
+ "npm": ">1.0"
},
"devDependencies": {
"node-static": "~0.6.1",
@@ -62,10 +62,6 @@
"test": "./tests/run.js test -u --group server --driver nodejs && ./tests/run.js test -u --group client --driver selenium"
},
"yahoo": {
- "bugzilla": {
- "product": "Mojito",
- "component": "General"
- },
"mojito": {
"type": "bundle",
"location": "lib/app"

3 comments on commit 43cd1e4

@rwaldura

Well, that seems to be a bit more than what I was requesting...
Does this say Mojito isn't compatible with Node 4.x, or NPM 1.x?

@isao
Owner
isao commented on 43cd1e4 Sep 13, 2012

hm, it says any node greater than 0.4 and npm greater than 1.0, but not including these exact versions.

do you want me to update to >=? However, I think a scenario where the patch version is zero and a benefit of any kind is unlikely.

@rwaldura

To summarize our chat: we want to declare Mojito compatible will all versions of Node, starting with Node 0.4.x
Same for NPM 1.x.
Where 'x' is the latest version.

Please sign in to comment.
Something went wrong with that request. Please try again.