Rewrite the Vista-IO-Plugin #19

Open
Rollmops opened this Issue May 13, 2011 · 4 comments

Comments

Projects
None yet
3 participants
Owner

Rollmops commented May 13, 2011

Since the Vista plugin was written in a very hurry and so lacks of performance and transparancy, we have to start all over again and rewrite it.

@ghost ghost assigned DerOrfa May 13, 2011

Owner

rollwurst commented May 13, 2011

Since this is not a very urgent issue and I would love to write some code again (beside doing packaging, orga and being the slave driver) I would like to have my hands on this.
By the way: there was a discussion about the parser generator. It is planned to use the Boost:Spirit PG. And there was a rumor that this would break our current minimum requirement for the boost library (1.35, lenny) But according to the boost web page it's there since version 1.30.0 and also available in the Debian package libboost-1.34-dev.
Am I missing anything??

Owner

DerOrfa commented May 13, 2011

I'd strongly recommend to use boost::spirit v2.
It's a complete rewrite introduced in boost 1.37.

The old version had some issues like being complex even for simple grammars and it was damn slow.

But the api was redesigned as well (which is a good thing). So we would loose compatibility to boost < 1.37.

@DerOrfa DerOrfa closed this May 13, 2011

@DerOrfa DerOrfa reopened this May 13, 2011

Owner

rollwurst commented May 13, 2011

I see. On second thoughts I will discard my old statement using bison & flex to keep up with older GNU/Linux releases (e.g. < Debian Squeeze) and will also vote for Spirit.

But this is no "Go!" for using every bleeding edge library available just to get new cool features ;-). In general it still holds that we should try to stay on "Debian stable" level.

PS.: The "comment & close" button is at a very tricky position, right?... ;-)

@ghost ghost assigned rollwurst May 13, 2011

Owner

DerOrfa commented Jun 23, 2011

Just for the record.
This would mean we need at least debian squeeze (stable). lenny only has boost 1.35 (and 1.34 - both are to old)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment