Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Suppress Ruby warnings #284

Merged
merged 2 commits into from Jan 21, 2019

Conversation

Projects
None yet
2 participants
@pocke
Copy link
Contributor

commented Jan 21, 2019

With RUBYOPT=-w, Ruby reports some warnings of Itamae.
This pull request will suppress two warnings.

Please read each commit message to know what the commit changes.

This change does not change Itamae behavior basically. But it will break on an edge case. It will break If some library has require 'itamae/recipe and so on. I think the requiring is unnecessary, so I hope this pull request does not break any code.


Note: Ruby still warns with this pull request, but the warnings are for dependencies (e.g. specinfra). So we should fix the dependencies to avoid all warnings.

pocke added some commits Jan 21, 2019

Remove redundant `require 'itamae'` to avoid warnings
before
===

```
$ itamae --help
/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:2:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/runner.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/recipe.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:2:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/base.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/file.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/package.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:5:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/remote_directory.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:6:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/remote_file.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:7:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/directory.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:8:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/template.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:9:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/http_request.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:10:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/execute.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:11:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/service.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:12:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/link.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:13:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/local_ruby_block.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:14:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/git.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:15:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/user.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:16:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/group.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:4:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource.rb:17:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/resource/gem_package.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:8:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/logger.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:9:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/node.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/redhat/base/package.rb:24: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/darwin/base/package.rb:33: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/darwin/base/package.rb:37: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/gentoo/base/package.rb:17: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/gentoo/base/package.rb:21: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/suse/base/package.rb:14: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:125: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:130: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:137: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:141: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/powershell/command.rb:9: warning: `&' interpreted as argument prefix
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/powershell/command.rb:31: warning: assigned but unused variable - identity
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/telnet.rb:64: warning: assigned but unused variable - retry_prompt
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/net-telnet-0.1.1/lib/net/telnet.rb:576: warning: mismatched indentations at 'else' with 'if' at 562
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/processor.rb:171: warning: assigned but unused variable - match
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/processor.rb:222: warning: assigned but unused variable - match
/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:11:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/notification.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54: warning: loading in progress, circular require considered harmful - /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `<main>'
	from /home/pocke/.rbenv/versions/trunk/bin/itamae:23:in  `load'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/bin/itamae:3:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/cli.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae.rb:12:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/definition.rb:1:in  `<top (required)>'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'
	from /home/pocke/.rbenv/versions/trunk/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:54:in  `require'

/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
Commands:
  itamae destroy [cookbook|role] [NAME]   # Undo role or cookbook (short-cut alias: "d")
  itamae docker RECIPE [RECIPE...]        # Create Docker image
  itamae generate [cookbook|role] [NAME]  # Initialize role or cookbook (short-cut alias: "g")
  itamae help [COMMAND]                   # Describe available commands or one specific command
  itamae init NAME                        # Create a new project
  itamae jail RECIPE [RECIPE...]          # Run Itamae in jail
  itamae local RECIPE [RECIPE...]         # Run Itamae locally
  itamae ssh RECIPE [RECIPE...]           # Run Itamae via ssh
  itamae version                          # Print version
```

after
===

```
$ itamae --help
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/redhat/base/package.rb:24: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/darwin/base/package.rb:33: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/darwin/base/package.rb:37: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/gentoo/base/package.rb:17: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/gentoo/base/package.rb:21: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/command/suse/base/package.rb:14: warning: assigned but unused variable - cmd
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:125: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:130: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:137: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/ssh.rb:141: warning: ambiguous first argument; put parentheses or a space even after `/' operator
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/powershell/command.rb:9: warning: `&' interpreted as argument prefix
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/powershell/command.rb:31: warning: assigned but unused variable - identity
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/backend/telnet.rb:64: warning: assigned but unused variable - retry_prompt
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/net-telnet-0.1.1/lib/net/telnet.rb:576: warning: mismatched indentations at 'else' with 'if' at 562
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/processor.rb:171: warning: assigned but unused variable - match
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/specinfra-2.76.5/lib/specinfra/processor.rb:222: warning: assigned but unused variable - match
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/thor-0.20.3/lib/thor.rb:396: warning: global variable `$thor_runner' not initialized
Commands:
  itamae destroy [cookbook|role] [NAME]   # Undo role or cookbook (short-cut alias: "d")
  itamae docker RECIPE [RECIPE...]        # Create Docker image
  itamae generate [cookbook|role] [NAME]  # Initialize role or cookbook (short-cut alias: "g")
  itamae help [COMMAND]                   # Describe available commands or one specific command
  itamae init NAME                        # Create a new project
  itamae jail RECIPE [RECIPE...]          # Run Itamae in jail
  itamae local RECIPE [RECIPE...]         # Run Itamae locally
  itamae ssh RECIPE [RECIPE...]           # Run Itamae via ssh
  itamae version                          # Print version

```
Suppress uninitialized instance variable warning
```
/home/pocke/.rbenv/versions/trunk/lib/ruby/gems/2.7.0/gems/itamae-1.10.3/lib/itamae/logger.rb:82: warning: instance variable (at)color not initialized
```
@k0kubun

This comment has been minimized.

Copy link
Member

commented Jan 21, 2019

👍

@k0kubun k0kubun merged commit 66f0de8 into itamae-kitchen:master Jan 21, 2019

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@pocke pocke deleted the pocke:w branch Jan 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.