Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

How to configure Server Side Encryption (S3) #10052

Closed
cyberduck opened this issue Aug 16, 2017 · 3 comments
Closed

How to configure Server Side Encryption (S3) #10052

cyberduck opened this issue Aug 16, 2017 · 3 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Aug 16, 2017

ff8cc21 created the issue

I configured SSE-S3 (AES-256) on Preference, and then tried to use Server Side Encryption (SSE), but it seems SSE is invalid for my bucket/object. I only read and configured as follows documentation.

According to cyberduck debug logging (defaults write ch.sudo.cyberduck logging debug), I wonder x-amz-server-side-encryption header is not set with PUT Object API when I upload new object? My configuration might be something wrong. After uploading, I cannot change "Encryption" field in S3 tab on Info dialog for the object.

Could you confirm that SSE works on your environment and above documentation is appropriate?

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 14, 2017

@dkocher commented

The documentation should be correct. You can either select the encryption setting in Preferences to use SSE for uploads by default or override these default settings in the File → Info (⌘-I) → S3 panel per bucket.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 14, 2017

@dkocher commented

Please attach a screenshot that shows the issue running the latest version and reopen this issue.

Loading

@cyberduck cyberduck closed this Oct 14, 2017
@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 16, 2017

ff8cc21 commented

Did you confirm that x-amz-server-side-encryption header is set when you upload a file using debug mode?

Loading

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant