Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AWS GovCloud S3: Failure to read attributes of <bucket> #10596

Closed
cyberduck opened this issue Feb 5, 2019 · 5 comments
Closed

AWS GovCloud S3: Failure to read attributes of <bucket> #10596

cyberduck opened this issue Feb 5, 2019 · 5 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Feb 5, 2019

e51fc8f created the issue

I am getting the following error when transferring a file or directory from a GovCloud S3 bucket to a local path:

Failure to read attributes of <bucket>.

The request contained an unsupported argument. Please contact your web hosting service provider for assistance.

The directory listing is working as expected. I just run into this error when trying to download files. I verified this is working correctly in the commercial cloud accounts (e.g. us-west-1) but not GovCloud.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 5, 2019

@dkocher commented

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac or right-click the toolbar from the Transfers window and choose Log on Windows.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 5, 2019

@dkocher commented

Amazon S3 Transfer Acceleration is not available in the AWS GovCloud (US-West) Region.
Amazon S3 Transfer Acceleration is not available in the AWS GovCloud (US-East) Region.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 5, 2019

@dkocher commented

Possibly fixed with bd0b17b.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 5, 2019

e51fc8f commented

Replying to [comment:5 dkocher]:

Possibly fixed with bd0b17b.

Hi dkocher,

I just installed Version 6.9.3 (29975) and unfortunately I'm running into the same issue. I tried getting the logs, but no logs show up during the download. I see logs when doing the directory listing.

Thanks!

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 6, 2019

@dkocher commented

Additional fix in 27e7239.

Loading

@cyberduck cyberduck closed this Feb 6, 2019
@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants