Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Open web URL does not include custom port number #11017

Closed
cyberduck opened this issue Apr 5, 2020 · 5 comments
Closed

Open web URL does not include custom port number #11017

cyberduck opened this issue Apr 5, 2020 · 5 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Apr 5, 2020

b87c3bc created the issue

I do not use the standard port numbers on my webdav server. Therefore I have specified a specific port number for webdav over HTTPS in cyberduck.
When I use the option "Copy Web URL" I get the proper url. However when I use the option "open web url" the port number is not included in the url so that option does not work unless I insert the port number in te browser's URL line afterwards.


Attachments

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 16, 2020

@dkocher commented

I cannot reproduce this issue. Configure the Web URL in the bookmark accordingly to include the port number.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 16, 2020

b87c3bc commented

I am getting this on all machines that connect to my server.
The URL appears properly on the bookmark config page with the port otherwise I would not be able to connect at all. It also appears properly on the Copy URL entry but not on the open web URL entry.
Maybe you can try it on my server. I created a test account for you;

Hostname: jdvl.nl
webdav HTTPS port: 51006
userid: cyberduck
pw: Ro1drigues$

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 16, 2020

@dkocher commented

Can you provide a screenshot of your bookmark configuration.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 16, 2020

b87c3bc commented

I just filled in the the field "Web URL" under "more options" with the url that includes the custom port number and the path that is specified in the path field. So I filled in "https://jdvl.nl:51006/video"
That seems to overide the default url that is generated when you do not fill in anything in the "Web URL field. Now it works but that is counter intuitive. On the "Copy Url" option the custom port number and path is filled by cyberduck by default while on the default "Open URL this is not the case. This appears to me as very inconsistent in its behaviour.

I can understand that it will not fill in the port and path once you fill the "web url" field but it should be included it on the default generated url when you do not fill the "Web url" field. In fact when you look under copy URL it generates two defaults. One with the custom port number and path and one without. Personally I never use the latter since that doesn't work because it is never the proper URL because of that missing info.

So we should change this defects name to: Open URL does not include custom port number or path in default URL

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 21, 2020

@dkocher commented

We include both the Origin URL with the port number you connect to in Cyberduck as well as the configured HTTP URL if any. Documentation ca be found in the wiki.

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 27, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Development

No branches or pull requests

1 participant