Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Disconnects after creating directory... even if there are more files to upload #1142

Closed
cyberduck opened this issue Jun 20, 2007 · 12 comments
Closed
Assignees
Labels
bug fixed ftp high priority
Milestone

Comments

@cyberduck
Copy link
Collaborator

cyberduck commented Jun 20, 2007

prattboy created the issue

When I try to upload a series of files and directories with one drag and drop, Cyberduck appears to disconnect and then immediately reconnect if the following condition is met:

-The files being uploaded contain a directory.

Cyberduck will create the directory but then appears to disconnect and reconnect. This stops the upload process, even if there are additional files to upload.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 21, 2007

@dkocher commented

Are you running 2.7.2. Use Cyberduck > Check for Update...

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 21, 2007

prattboy commented

No. I'm using 2.7.3

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 22, 2007

58dcc38 commented

me too. I'm using 2.7.3 (2930) and I keep needing to hit "resume" during an upload of a directory that contains other folders and files. also sync halts...

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 22, 2007

58dcc38 commented

seems to be same/similar to issue in (closed) ticket #1001

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 22, 2007

prattboy commented

I have FTP access on two different servers. On one server, I have this error. On the other, I do not. How do I give access to the appropriate parties for testing?

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 22, 2007

@dkocher commented

Please post the log which is displayed in the error dialog when the transfer halts.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 22, 2007

prattboy commented

The plot thickens. There is no error dialog. The transfer window just says "Disconnected" and it stops transferring.

Something additional information that might be helpful:

If I create the directories via OS X, there seems to be no problem with them when uploading. Many (if not all) the directories I'm having trouble with have been uncompressed from tar.gz files via Stuffit Expander v 11.0.2 (Intel build 627).

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 23, 2007

58dcc38 commented

yes there is no dialog error for me either (unless I just am not looking in the secret error place? grin let me know where to look). My window also just says disconnected and stops. I am also uploading from an archive I have decompressed. I'm happy to provide any details you need, just let me know.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 24, 2007

@dkocher commented

Is this for FTP or SFTP transfers? Also, do you see the same problem in the latest build at (http://update.cyberduck.ch/nightly/) (currently 58c7ad9)?

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 25, 2007

prattboy commented

Alrighty... it's not all archives that I uncompress, and those that give me trouble seem to work okay if I use an application other than Stuffit Expander to uncompress them. I specifically have trouble with the tar.gz modules downloaded from drupal.org

This is via FTP. I have not used SFTP to test. The latest build, ef57a0d (it looks like there was one additional release prior to this post, dkocher) seems to have the same issues (although the revised transfer window looks very nice).

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 25, 2007

@dkocher commented

Thanks for the additinal info. I will look into this.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 25, 2007

@dkocher commented

Fixed in 2490c0d.

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug fixed ftp high priority
Projects
None yet
Development

No branches or pull requests

2 participants