Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support MacVim as one of the external editors #1322

Closed
cyberduck opened this issue Nov 2, 2007 · 7 comments
Closed

Support MacVim as one of the external editors #1322

cyberduck opened this issue Nov 2, 2007 · 7 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Nov 2, 2007

046213a created the issue

Hello:

can you please add "MacVim" as one of the possible external editors. MacVim is a Cocoa version of the popular vim edito. MacVim is a GUI version with support for tabs and such.

Check it out at (http://code.google.com/p/macvim/)
With some screen shots at (http://macvim.googlecode.com/files/Macvim-screenshot-7.jpg)

We currently change the editor.name to MacVim using defaults tool but would be nice if it is there in 2.8.1 After all both are open source :-)

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Nov 2, 2007

046213a commented

Sorry... changed the issue to enhancement instead of bug.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Nov 2, 2007

@dkocher commented

Currently we only support editors that support the ODB protocol (http://www.barebones.com/support/develop/odbsuite.shtml).

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Dec 4, 2007

@dkocher commented

You can use the commands

defaults write ch.sudo.cyberduck editor.bundleIdentifier org.vim.MacVim
defaults write ch.sudo.cyberduck editor.name MacVim

to test your implementation with Cyberduck.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Dec 6, 2007

@dkocher commented

As of 27171fa we support MacVim if it has the bundle identifier org.slashpunt.vim

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Dec 11, 2007

@dkocher commented

Reverted in f0eea55. I need a confirmation about a publicly released version of MacVim which supports ODB then we can enable it by default. Also see #1399.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Dec 12, 2007

@dkocher commented

It doesn't work here using MacVim-snapshot-0712B.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Dec 20, 2007

@dkocher commented

It does work as of MacVim 0712B. Fixed in f8afd9a.

@cyberduck cyberduck closed this Dec 20, 2007
@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants