Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot upload to write-only FTP site, disconnects after LIST

Closed
cyberduck opened this issue Aug 5, 2010 · 3 comments
Closed

Cannot upload to write-only FTP site, disconnects after LIST #5083

cyberduck opened this issue Aug 5, 2010 · 3 comments
Assignees
Labels
bug ftp thirdparty
Milestone

Comments

@cyberduck
Copy link
Collaborator

cyberduck commented Aug 5, 2010

e05ee1e created the issue

I am connecting to a write-only FTP site. When I connect, Cyberduck throws an error that access is denied for the LIST -a command. After that error, Cyberduck disconnects from the site, so I cannot upload to it.

Preferred behavior would be to prompt with the error, but maintain the connection so that the user can upload files to the write-only directory. The error message itself should contain the information that this may be a write-only directory, so it doesn't confuse the user.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Aug 5, 2010

@dkocher commented

That should be fixed in the current snapshot build. Please give it a try and report back.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Aug 5, 2010

e05ee1e commented

Re-opening this, since there's still a problem. Testing using latest snapshot build (3.6 build 6559)

When I connect, it hangs on "Listing directory ". Transcript is as follows:

220 Microsoft FTP Service
FEAT
530 Please login with USER and PASS.
USER xxxx
331 Password required for xxxx.
PASS ********
230 User xxxx logged in.
PWD
257 "/upload" is current directory.
NOOP
200 NOOP command successful.
SYST
215 Windows_NT
STAT /upload
213-status of /upload:
213 End of status.
PORT 10,1,3,5,248,201
200 PORT command successful.
LIST -a
150 Opening ASCII mode data connection for /bin/ls.

I then tried disabling list commands (all of them), and end up with a disconnect with "2 bookmarks" in the status bar. Transcript there is:


220 Microsoft FTP Service
USER japs
331 Password required for japs.
PASS ********
230 User japs logged in.
FEAT
211-FEAT
    SIZE
    MDTM
211 END
PWD
257 "/japs" is current directory.
NOOP
200 NOOP command successful.
SYST
215 Windows_NT
PASV
227 Entering Passive Mode (12,2,77,227,13,232).
LIST
125 Data connection already open; Transfer starting.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Aug 5, 2010

@dkocher commented

Replying to [comment:2 https://www.google.com/accounts/o8/id?id=aitoawmzikh8lrneathzoauemj0_vbiefbmqwt8]:

Re-opening this, since there's still a problem. Testing using latest snapshot build (3.6 build 6559)

Thanks for the additional information. The server should response error message denying access to the directory. Instead it just ignores the LIST request which is not according to the FTP protocol. Please report to the server vendor.

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug ftp thirdparty
Projects
None yet
Development

No branches or pull requests

2 participants