Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

illegal port command using FTPS transfer #5850

Closed
cyberduck opened this issue Mar 28, 2011 · 5 comments
Closed

illegal port command using FTPS transfer #5850

cyberduck opened this issue Mar 28, 2011 · 5 comments
Assignees
Labels
bug ftp-tls FTP (TLS) Protocol Implementation worksforme
Milestone

Comments

@cyberduck
Copy link
Collaborator

cyberduck commented Mar 28, 2011

69459ad created the issue

after upgrade to 4.0.2, every time I use FTP-SSL connection to transfer files from my transfer server, it errors out with illegal PORT command. I can use plain FTP to transfer file with no issue on this version.

I used 4.0.1 with no such error. There is no change in the ProFTPD version used on the server side, still 1.3.3a.

I set the Severity to high because I cannot transfer using FTP-SSL anymore.

Thanks in advance for looking into this problem. I have uploaded the log drawer transcript.


Attachments

@cyberduck
Copy link
Collaborator Author

cyberduck commented Mar 29, 2011

@dkocher commented

Switch to passive (PASV) connect mode.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Mar 29, 2011

69459ad commented

Hi - I have not change the bookmark since I upgraded to V4.0.2... wondering why it worked before. I have tried to set it to PASV mode and it worked OK. For plain FTP, ACTIVE mode worked just fine. Sounded like an issue... but I got an resolution. Not a problem anymore.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Mar 29, 2011

@dkocher commented

Replying to [comment:2 lee.norman@…]:

Hi - I have not change the bookmark since I upgraded to V4.0.2... wondering why it worked before. I have tried to set it to PASV mode and it worked OK. For plain FTP, ACTIVE mode worked just fine. Sounded like an issue... but I got an resolution. Not a problem anymore.

This change was made in 5029426. We have no more an automatic fallback for general FTP errors when opening data sockets.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jun 2, 2011

@dkocher commented

Milestone 4.0.3 deleted

@cyberduck
Copy link
Collaborator Author

cyberduck commented Mar 17, 2015

9e5c471 commented

Full Complete solution for "ftp 500 Illegal PORT command".
Click the following link:

(http://www.ucodice.com/articles/ftp-500-illegal-port-command/)

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug ftp-tls FTP (TLS) Protocol Implementation worksforme
Projects
None yet
Development

No branches or pull requests

2 participants