Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot connect to Eucalyptus Community Cloud - I/O Error : Connection Failed #6207

Closed
cyberduck opened this issue Sep 7, 2011 · 7 comments
Closed

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Sep 7, 2011

3ebe121 created the issue

Trying to connect to Eucalyptus' community cloud Walrus service.

Community URL: (https://ecc.eucalyptus.com:8443/)

Was able to connect with JetS3t's Cockpit (same system), upload a file, and create the following public URL for an item: (http://ecc.eucalyptus.com:8773/services/Walrus/chimpeenuts-bucket/Argentina.gif)

UPDATE: Can get CloudBerry Explorer LITE on Windows to connect to community cloud.

See attached screenshot for connection settings and specified Query ID and Secret Key.

When I try to connect I get error: 'I/O Error: Connection failed - Unrecognized SSL message, plaintext connection?" with an option to Cancel or Try Again. Clicking Try Again brings up the same error message. (see attached screenshot)

When I click on the URL (with no username or secret key) inside the connection window, I get an error message indicating 'no such user' but this is expected (since I'm not supplying any user credentials) and GOOD because means I'm reaching the service and it does indeed exist:

<Error xmlns="http://s3.amazonaws.com/doc/2006-03-01/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<Resource>no such user</Resource>
<RequestId>36844774-a99b-44e9-a2a5-b2ddee9a5d3a</RequestId>
</Error>

Attachments

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

I can replicate the issue here. I haven't looked into it closely yet but it looks like a SSL negogiation issue. Similarly if I connect to https://ecc.eucalyptus.com/ in a web browser get an error establishing a secure connection. In particular Chrome gives a ERR_NO_SSL_VERSIONS_ENABLED.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

Replying to [comment:2 dkocher]:

I can replicate the issue here. I haven't looked into it closely yet but it looks like a SSL negogiation issue. Similarly if I connect to https://ecc.eucalyptus.com/ in a web browser get an error establishing a secure connection. In particular Chrome gives a ERR_NO_SSL_VERSIONS_ENABLED.

Sorry, that information is wrong. I was attempting to connect to port 443 instead of 8443 .

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

3ebe121 commented

Keep in mind that the Eucalyptus Cloud Web Interface is often run on port 8443, but the Eucalyptus Walrus server is often on port 8773. One "enhancement" I saw to make in CyberDuck is that when you create a new Walrus endpoint, Cyberduck uses a default port of 8443, which is actually confusing since it should be 8773 since that's the usual default port for Eucalyptus Walrus.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

Replying to [comment:5 chimpeenuts]:

Keep in mind that the Eucalyptus Cloud Web Interface is often run on port 8443, but the Eucalyptus Walrus server is often on port 8773. One "enhancement" I saw to make in CyberDuck is that when you create a new Walrus endpoint, Cyberduck uses a default port of 8443, which is actually confusing since it should be 8773 since that's the usual default port for Eucalyptus Walrus.

Default port changed in 9bc8a19.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

The default port was not taken into account at all thus trying to connect to the 443 instead. Fix in 756d4b4.

Loading

@cyberduck cyberduck closed this Sep 7, 2011
@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

#6206 closed as duplicate.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Sep 7, 2011

@dkocher commented

A new snapshot build with the fix included will be available in a few minutes.

Loading

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants