Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Missing or Inaccessible Content when using WebDav #6300

Closed
cyberduck opened this issue Oct 10, 2011 · 4 comments
Closed

Missing or Inaccessible Content when using WebDav #6300

cyberduck opened this issue Oct 10, 2011 · 4 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Oct 10, 2011

Snottmonster created the issue

I have v 4.1 and v4.0 installed under OSX 10.7.1

When accessing my WebDav server, the v4.0.2 client lists all available content, but the v4.1.3 client does not - many files and folders are missing.

Also, the v4.1.3 client often lists folders as inaccessible (small no-entry overlay icon) which are fully accessible from the v4.0.2 client

WebDav service is provided by the application Ajaxplorer (http://www.ajaxplorer.info) which states it is using a "PHP implementation of the webDAV protocol (using ezComponent library)"

OS X Finder also shows the full content when used to access the same repository

This issue can be verified by accessing a public read-only WebDav repository at: https://sphardy.com/explorer/files/public

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 10, 2011

Snottmonster commented

I have now noticed that CyberDuck v 4.0.2 is also omitting content and marking certain folders as inaccessible.

I have checked the underlying permissions of the files/folders affected and I can see no differences or reasons why that content should not be available. Also, the fact that 2 different versions of the client show the same symptoms against the same server, but with different content on that server is odd.

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 10, 2011

@dkocher commented

This is because the server does not properly URI encode references in the XML response. With the new WebDAV implementation in Cyberduck, we are no more strict and ignore invalid responses. Please file a bug report with the developers of Ajaxplorer.

For example the following URI is returned

https://sphardy.com/explorer/files/public/00 How To Upload Files.txt

The whitespace in the filename should be encoded with %20.

Loading

@cyberduck cyberduck closed this Oct 10, 2011
@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 11, 2011

Snottmonster commented

Many thanks for the investigation - I will report to the Ajaxplorer team

Loading

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Mar 8, 2012

@dkocher commented

Duplicate for #6094.

Loading

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants