Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

webdav was broken in cyberduck v4.3.1 #7266

Closed
cyberduck opened this issue May 24, 2013 · 3 comments
Closed

webdav was broken in cyberduck v4.3.1 #7266

cyberduck opened this issue May 24, 2013 · 3 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented May 24, 2013

0992d77 created the issue

webdav was broken in v4.3.1

I have tried the webdav testing server
http://test.webdav.org/

both http://test.webdav.org/auth-basic/ and http://test.webdav.org/auth-digest/ returned a Not Found error.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented May 24, 2013

@dkocher commented

The server is misconfigured as that it does erroneously return a 404 for HEAD requests. The RFC says

The HEAD method is identical to GET except that the server MUST NOT return a message-body in the response. The metainformation contained in the HTTP headers in response to a HEAD request SHOULD be identical to the information sent in response to a GET request. This method can be used for obtaining metainformation about the entity implied by the request without transferring the entity-body itself. This method is often used for testing hypertext links for validity, accessibility, and recent modification.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Jun 20, 2013

@dkocher commented

Duplicate for #7227.

@cyberduck cyberduck closed this Jun 20, 2013
@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Jun 20, 2013

@dkocher commented

Looks like the test server is returning a 404 also for PROPFIND requests. There is possibly a configuration issue.

yuksom:~ dkocher$ curl -vX PROPFIND http://test.webdav.org/dav/
* About to connect() to test.webdav.org port 80 (#0)
*   Trying 140.211.166.111...
* Adding handle: conn: 0x7fed68809000
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x7fed68809000) send_pipe: 1, recv_pipe: 0
* Connected to test.webdav.org (140.211.166.111) port 80 (#0)
> PROPFIND /dav/ HTTP/1.1
> User-Agent: curl/7.30.0
> Host: test.webdav.org
> Accept: */*
> 
< HTTP/1.1 404 Not Found
< Date: Thu, 20 Jun 2013 09:03:35 GMT
* Server Apache/2.0.54 (Debian GNU/Linux) DAV/2 SVN/1.3.2 is not blacklisted
< Server: Apache/2.0.54 (Debian GNU/Linux) DAV/2 SVN/1.3.2
< Content-Length: 202
< Content-Type: text/html; charset=iso-8859-1
< 
<!DOCTYPE HTML PUBLIC "_IETF_DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /dav/ was not found on this server.</p>
</body></html>
* Connection #0 to host test.webdav.org left intact

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants