Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Timeout opening data connection with PORT #8350

Closed
cyberduck opened this issue Nov 21, 2014 · 7 comments
Closed

Timeout opening data connection with PORT #8350

cyberduck opened this issue Nov 21, 2014 · 7 comments
Assignees
Labels
bug ftp-tls FTP (TLS) Protocol Implementation worksforme
Milestone

Comments

@cyberduck
Copy link
Collaborator

cyberduck commented Nov 21, 2014

fdf8ba3 created the issue

FTP-SSL Explicit AUTH TLS -mode hasn't been working since 4.5 in Active mode.

Works fine on 4.6 in Passive mode, but not in Active.

Everything worked fine on the exactly same server, account and file with 4.4.5.

Attaching screenshots for Download and Upload and a transcript for Download.


Attachments

@cyberduck
Copy link
Collaborator Author

cyberduck commented Nov 25, 2014

@dkocher commented

Using PORT mode is expected to fail with the computer having a local IP address 192,168,253,93 assigned. What is the reason to want to use active mode?

@cyberduck
Copy link
Collaborator Author

cyberduck commented Nov 25, 2014

fdf8ba3 commented

Because the server is also inside the NAT network. Using PORT mode inside and PASV outside is the only way to get everything to work for both internal and external users.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Nov 25, 2014

@dkocher commented

Everything looks fine from the transcript but the server does not give a reply. Have you checked that your computer firewall (System Preferences → Security & Privacy → Firewall) accepts incoming connections to accept the connect from the server?

@cyberduck
Copy link
Collaborator Author

cyberduck commented Nov 25, 2014

fdf8ba3 commented

Alsolutely sure that the firewall is not active. Also, on the exactly same client computer running 4.4.5 PORT mode works fine. With 4.5+, times out every time.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jan 25, 2015

@dkocher commented

Replying to [comment:5 saku_localeyes]:

Alsolutely sure that the firewall is not active. Also, on the exactly same client computer running 4.4.5 PORT mode works fine. With 4.5+, times out every time.

Can you please post the transcript from this version to compare.

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jan 26, 2015

fdf8ba3 commented

How do I get a transcript for a download that doesn't fail?

@cyberduck
Copy link
Collaborator Author

cyberduck commented Jan 26, 2015

@dkocher commented

Replying to [comment:8 saku_localeyes]:

How do I get a transcript for a download that doesn't fail?

Please post the transcript from the log drawer (⌘-L) of the Transfers window.

@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug ftp-tls FTP (TLS) Protocol Implementation worksforme
Projects
None yet
Development

No branches or pull requests

2 participants