Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support new OpenSSH key format #8548

Closed
cyberduck opened this issue Feb 4, 2015 · 7 comments
Closed

Support new OpenSSH key format #8548

cyberduck opened this issue Feb 4, 2015 · 7 comments

Comments

@cyberduck
Copy link
Collaborator

@cyberduck cyberduck commented Feb 4, 2015

398c125 created the issue

More recent OpenSSH version are using a new OpenSSH key format (see http://www.tedunangst.com/flak/post/new-openssh-key-format-and-bcrypt-pbkdf) - Cyberduck currently does not understand that version and comes back with

Exhausted available authentication methods. Unrecognised object: OPENSSH PRIVATE KEY.
@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 6, 2015

5586502 commented

Hi DrWhoZee,

I didn't see your ticket before I opened #8553. Your link talks about ecdsa and ed25519 keys. According to https://stribika.github.io/2015/01/04/secure-secure-shell.html, only the latter is really secure. In case you want support for ed25519 keys, my ticket is a duplicate of yours. If you want ecdsa, you might want to change your mind about that ;-)

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Feb 6, 2015

398c125 commented

No, this is not about ecdsa, this ticket is about the new OpenSSH private key format - the link just serves as the reference to the new format.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 1, 2016

aeeef44 commented

Support for ed25519 keys (#8553) must require this issue because newly generated ed25519 keys are only in new OpenSSH format.

I receive

Login failed. Exhausted available authentication methods. Unrecognised object: OPENSSH PRIVATE KEY. Please contact your web hosting service provider for assistance.

error in nighly duck cli or OS X Version 4.8.4 (19355)

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Apr 12, 2016

@dkocher commented

#9440 closed as duplicate.

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 19, 2016

@dkocher commented

Milestone renamed

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 19, 2016

@dkocher commented

Ticket retargeted after milestone closed

@cyberduck
Copy link
Collaborator Author

@cyberduck cyberduck commented Oct 29, 2016

@dkocher commented

In 6e347be.

@cyberduck cyberduck closed this Oct 29, 2016
@iterate-ch iterate-ch locked as resolved and limited conversation to collaborators Nov 26, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants