build fails #20

Closed
mcandre opened this Issue Sep 13, 2012 · 3 comments

Comments

Projects
None yet
2 participants

mcandre commented Sep 13, 2012

The build process fails due to an error during autoreconf.

Trace:

$ autoreconf -i
C:\MinGW\bin\libtoolize: putting auxiliary files in `.'.
C:\MinGW\bin\libtoolize: copying file `./ltmain.sh'
C:\MinGW\bin\libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
C:\MinGW\bin\libtoolize: copying file `m4/libtool.m4'
C:\MinGW\bin\libtoolize: copying file `m4/ltoptions.m4'
C:\MinGW\bin\libtoolize: copying file `m4/ltsugar.m4'
C:\MinGW\bin\libtoolize: copying file `m4/ltversion.m4'
C:\MinGW\bin\libtoolize: copying file `m4/lt~obsolete.m4'
configure.ac:117: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:401: error: possibly undefined macro: AS_IF
autoreconf-2.67: /mingw/bin/autoconf-2.67 failed with exit status: 1

Specs:

  • git bdwgc
  • gcc.exe (GCC) 4.5.2
  • MinGW version 0.1-alpha-5.1
  • MSYS 1.0
  • Windows 7 Professional x64
  • MacBook Pro
Owner

ivmai commented Sep 13, 2012

Yes, this is known problem. As temporary workaround, please run ./autogen.sh on a Linux host (e.g. Ubuntu)

mcandre commented Nov 23, 2012

I develop my software for Windows. This doesn't help me at all.

Owner

ivmai commented Aug 25, 2013

I see, but nobody suggested the proper fix for MinGW yet, so the workaround is to use Linux to regenerate configure and switch back to Windows.

@ivmai ivmai closed this Aug 25, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment