New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

macOS 10.10 compatibility issues (was: Corrupted DMG on MAC OSX 10.10) #3

Closed
wanglongqi opened this Issue Jan 6, 2019 · 7 comments

Comments

Projects
None yet
2 participants
@wanglongqi
Copy link

wanglongqi commented Jan 6, 2019

I downloaded three versions of the released dmg. All return the same error message. Is my Mac OS version too old and not supported?

MD5 (Archive.Mounter.1.3.0.dmg) = b15f7ec426b7ff9751e00112db8b0436
MD5 (Archive.Mounter.1.3.1.dmg) = 2c1044d32b20812a93b3fe2768494b92
MD5 (Archive.Mounter.1.4.0.dmg) = 12f453b5aef4a5b66f2b7d2f4d49635e

image

@ivoronin ivoronin self-assigned this Jan 6, 2019

@ivoronin

This comment has been minimized.

Copy link
Owner

ivoronin commented Jan 6, 2019

Checksums are all good.
Release disk images are compressed using lzfse algorithm introduced in 10.11.
Please check the attached zip.
Archive.Mounter.1.4.0.zip
Let me know if software is working on 10.10.

@wanglongqi

This comment has been minimized.

Copy link

wanglongqi commented Jan 7, 2019

Thanks for the promptly reply. I am afraid the answer is no. The bundle fuse-zip is built for 10.13. I can compile fuse-zip under 10.10. So I think it is possible to make a release for 10.10.

Dyld Error Message:
Symbol not found: _syslog$DARWIN_EXTSN
Referenced from: Archive Mounter.app/Contents/Executables/fuse-zip (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

@ivoronin ivoronin changed the title Corrupted DMG on MAC OSX 10.10 macOS 10.10 compatibility issues (was: Corrupted DMG on MAC OSX 10.10) Jan 8, 2019

@ivoronin ivoronin added the bug label Jan 8, 2019

@ivoronin

This comment has been minimized.

Copy link
Owner

ivoronin commented Jan 8, 2019

Try this build please.
Archive.Mounter.1.4.1rc1.zip

@wanglongqi

This comment has been minimized.

Copy link

wanglongqi commented Jan 8, 2019

Great job, @ivoronin. It works on 10.10 now. Thanks! Since fuse-zip doesn't support zip file with password, it is understandable Archive Mounter also cannot support zip file with password.

@ivoronin

This comment has been minimized.

Copy link
Owner

ivoronin commented Jan 8, 2019

Fixed in v1.4.2

@ivoronin ivoronin closed this Jan 8, 2019

@ivoronin

This comment has been minimized.

Copy link
Owner

ivoronin commented Jan 9, 2019

@wanglongqi can you please run /Applications/Archive\ Mounter.app/Contents/Executables/rar2fs (with no arguments)?
I suspect there is another issue present.

@wanglongqi

This comment has been minimized.

Copy link

wanglongqi commented Jan 9, 2019

@ivoronin looks no problem.

Usage: rar2fs source mountpoint [options]
Try rar2fs -h' or rar2fs --help' for more information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment