Skip to content

@j0k3r j0k3r released this May 23, 2019 · 5 commits to master since this release

Major changes

The 2.0 started almost 2 years ago on an initiative of @aaa2000 👏 to add support for HTTPlug.

The 1.x was coupled to Guzzle 5 which is quite old now and some people started to complain about how coupled it was. It was obvious that the best solution was to switch to HTTPlug to let the final user decide which HTTP client to use.

The 2.0.0 is tested using these clients:

  • Guzzle 6
  • Guzzle 5
  • cURL

There are many more available HTTP client which should work too.

Other changes are:

  • dropping support PHP < 7.1
  • Tidy extension is now required
  • enable PHPStan level 7
  • open graph & json-ld are fetched first, information from the html overide them

If you want to upgrade, follow these steps.

Finally, huge thanks to @aaa2000 to have started the work 2 years ago. Also thanks to @jtojnar for helping me on that release.

Assets 2
You can’t perform that action at this time.