poppler-sharp.dll.config #4

Closed
elsupergomez opened this Issue Aug 29, 2011 · 2 comments

Comments

Projects
None yet
2 participants

Map library is for specific version 6 may be better no specify version

Actual:
dllmap dll="poppler-glib" target="libpoppler-glib.so.6"

Suggest:
dllmap dll="poppler-glib" target="libpoppler-glib.so"

Collaborator

hyperair commented Aug 29, 2011

I made it .so.6 to bind it to that particular ABI. If the ABI is broken, then we'll need to re-generate stuff via gapi, and look through the .custom files to see what needs to be added/removed.

Additionally, Debian and Ubuntu do not ship the .so symlinks with their binary packages. E.g. libpoppler-glib.so.6 is found in a package called libpoppler-glib6, and the .so symlink is found in libpoppler-glib-dev.

hyperair closed this Aug 29, 2011

Ok, thanks for reply, I try compile for Fedora 14 and version is so.5.
But in Fedora 15 is so.6

You are right.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment