Permalink
Switch branches/tags
Nothing to show
Find file
Fetching contributors…
Cannot retrieve contributors at this time
43 lines (31 sloc) 2.29 KB
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>A patched Jackrabbit for Jackalope</title>
</head>
<body>
<h1>A (not needed anymore) patched Jackrabbit for Jackalope</h1>
<p>As of now and since Jackrabbit 2.3.6, Jackrabbit provides all the patches it needs for all the features of
<a href="http://jackalope.github.com/">Jackalope</a> and PHPCR and <br/>
<b>you don't need a patched Jackrabbit right now anymore!</b>
</p>
<h2>Download Jackrabbit from Apache here:
</h2>
<p>
<a href="https://jackrabbit.apache.org/downloads.html">https://jackrabbit.apache.org/downloads.html</a> (get at least 2.3.6)
</p>
<h2>Outdated, just for reference: </h2>
<p>It's possible that with some progress we make on Jackalope, there are patches needed in the near future again. We try to
bring them into the official Jackrabbit tree as soon as possible.</p>
<p>Currently, we still maintain a patched version of Jackrabbit on <a href="https://github.com/jackalope/jackrabbit">https://github.com/jackalope/jackrabbit</a>, the (not mandatory) applied patches are described here:
<a href="https://github.com/jackalope/jackrabbit/blob/2.4-jackalope/README.jackalope.patches.md">https://github.com/jackalope/jackrabbit/blob/2.4-jackalope/README.jackalope.patches.md</a>
</p>
<p>The scripts for generating this site and the jar can be found here <a href="https://github.com/jackalope/create_jackrabbit4jackalope">https://github.com/jackalope/create_jackrabbit4jackalope</a></p>
<p>Here on this site we provide a compiled binary with all patches of jackrabbit-standalone-2.4.x-jackalope-SNAPSHOT.jar for convenience and an easy start (but it's not needed to get Jackalope 2012 running).
</p>
<p>
<a href="https://s3-eu-west-1.amazonaws.com/patched-jackrabbit/jackrabbit-standalone-2.4-jackalope-SNAPSHOT.jar">jackrabbit-standalone-2.4-jackalope-SNAPSHOT.jar</a> (if you have a jackalope build of 2012 and no special experimental requirements: <b>use the official build mentioned above</b>)<br/>
<a href="https://s3-eu-west-1.amazonaws.com/patched-jackrabbit/jackrabbit-standalone-2.2.8-jackalope-SNAPSHOT.jar">jackrabbit-standalone-2.2.8-jackalope-SNAPSHOT.jar</a> (needed for jackalope builds of 2011)<br/>
</p></body>
</html>