Permalink
Browse files

Initial commit.

  • Loading branch information...
0 parents commit 590bd17117482ba46442ecea2c3b0aeff868f91b @jcxplorer jcxplorer committed May 26, 2011
Showing with 62 additions and 0 deletions.
  1. +4 −0 .gitignore
  2. +2 −0 Gemfile
  3. +19 −0 README.md
  4. +2 −0 Rakefile
  5. +4 −0 lib/sproutcore-rails.rb
  6. +3 −0 lib/sproutcore-rails/version.rb
  7. +17 −0 sproutcore-rails.gemspec
  8. +11 −0 vendor/assets/javascripts/sproutcore.js
@@ -0,0 +1,4 @@
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
@@ -0,0 +1,2 @@
+source :rubygems
+gemspec
@@ -0,0 +1,19 @@
+SproutCore-Rails
+================
+
+SproutCore 2.0 for Rails 3.1.
+
+
+Getting started
+---------------
+
+Add the gem to your application Gemfile:
+
+ gem "sproutcore-rails"
+
+Run `bundle install` and add the following line to
+`app/assets/javascripts/application.js`:
+
+ //= require sproutcore
+
+
@@ -0,0 +1,2 @@
+require "bundler"
+Bundler::GemHelper.install_tasks
@@ -0,0 +1,4 @@
+module SproutCoreRails
+ class Engine < Rails::Engine
+ end
+end
@@ -0,0 +1,3 @@
+module SproutCoreRails
+ VERSION = "0.1.0"
+end
@@ -0,0 +1,17 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "sproutcore-rails/version"
+
+Gem::Specification.new do |s|
+ s.name = "sproutcore-rails"
+ s.version = SproutCoreRails::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Joao Carlos"]
+ s.email = ["contact@kiskolabs.com"]
+ s.homepage = "https://github.com/kiskolabs/sproutcore-rails"
+ s.summary = "SproutCore 2 for Rails 3.1."
+
+ s.files = %w(README.md) + Dir["lib/**/*", "vendor/**/*"]
+
+ s.require_paths = ["lib"]
+end

Large diffs are not rendered by default.

Oops, something went wrong.

0 comments on commit 590bd17

Please sign in to comment.