Chapter05 #14

Merged
merged 4 commits into from Nov 6, 2012

Projects

None yet

2 participants

@Funkmyster

Minor updates to Chapter05.
The link 'next chapter' wasn't going to Chapter 06
Updated DB configs to reflect 1.4

Jacob Silva added some commits Nov 4, 2012
@Funkmyster Funkmyster commented on the diff Nov 5, 2012
chapter05.rst
@@ -1380,7 +1384,5 @@ user-submitted form data.
But in some cases, you or your team might need to enter data manually, in which
case it would be helpful to have a Web-based interface for entering and
-managing data. The `next chapter`_ covers Django's admin interface, which exists
+managing data. The :doc:`next chapter <chapter06>` covers Django's admin interface, which exists
@Funkmyster
Funkmyster Nov 5, 2012

Changed relative link to the format used at the end of Chapter04.

@jacobian jacobian commented on an outdated diff Nov 5, 2012
chapter05.rst
- DATABASE_ENGINE = ''
- DATABASE_NAME = ''
- DATABASE_USER = ''
- DATABASE_PASSWORD = ''
- DATABASE_HOST = ''
- DATABASE_PORT = ''
+ DATABASES = {
+ 'default': {
+ 'ENGINE': '',
+ 'NAME': '',
+ 'USER': '',
+ 'PASSWORD': '',
+ 'HOST': '',
+ 'PORT': '',
+ },
+ }
@jacobian
jacobian Nov 5, 2012

This should probably use the exact snippet from the generated config file (i.e. with comments, etc.) instead of something similar.

@jacobian jacobian commented on an outdated diff Nov 5, 2012
chapter05.rst
the strings shown in Table 5-1.
.. table:: Table 5-1. Database Engine Settings
- ======================= ==================== ==============================================
- Setting Database Required Adapter
- ======================= ==================== ==============================================
- ``postgresql`` PostgreSQL ``psycopg`` version 1.x,
- http://www.djangoproject.com/r/python-pgsql/1/.
+ ============================================ ============ ================================================
+ Setting Database Required Adapter
+ ============================================ ============ ================================================
+ ``django.db.backends.postgresql`` PostgreSQL ``psycopg`` version 1.x,
+ http://www.djangoproject.com/r/python-pgsql/1/.
@jacobian
jacobian Nov 5, 2012

This backend's been deprecated in favor of the psycopg2 one; we shouldn't mention it.

@Funkmyster Funkmyster commented on the diff Nov 5, 2012
chapter05.rst
- ``mysql`` MySQL ``MySQLdb``,
- http://www.djangoproject.com/r/python-mysql/.
+ ``django.db.backends.sqlite3`` SQLite No adapter needed.
@Funkmyster
Funkmyster Nov 5, 2012

Adapter not needed as of Python 2.5 (minimum version of Django 1.4).

@jacobian jacobian merged commit 1127230 into jacobian-archive:master Nov 6, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment