Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Bug fixes.

  • Loading branch information...
commit 360213d3cdf6a41406c4cf7f47e7eea57f96f789 1 parent 0409a48
Jeremy Green authored
2  app/views/phocoder/multi_thumbnail_update.json.erb
@@ -2,6 +2,6 @@
2 2 <% @outputs.each_with_index do |output,i| %>
3 3 <% @img = output[:encodable] %>
4 4 <% @random = output[:random] %>
5   - "<%= output[:elem_id] %>" : "<%= escape_javascript(render(:partial=>"thumbnail_update.html.erb", :locals => {:params => output} )) %>" <%= "," if i != @outputs.size %>
  5 + "<%= output[:elem_id] %>" : "<%= escape_javascript(render(:partial=>"thumbnail_update.html.erb", :locals => {:params => output} )) %>" <%= "," if (i+1) != @outputs.size %>
6 6 <% end %>
7 7 }
5 public/javascripts/phocodable.js
@@ -14,6 +14,7 @@ Phocodable.JQueryUpdater = function(){
14 14 };
15 15
16 16 this.update = function(){
  17 + //console.log("starting update!!");
17 18 params = _self.build_update_params();
18 19 //console.debug(params);
19 20 if(params.length == 0){
@@ -25,11 +26,15 @@ Phocodable.JQueryUpdater = function(){
25 26 url : '/phocoder/multi_thumbnail_update.json',
26 27 dataType : 'json',
27 28 data : { encodables : params },
  29 + error : function(jqXHR, textStatus, errorThrown) {
  30 + //console.log(jqXHR); console.log(textStatus); console.log(errorThrown);
  31 + },
28 32 success : _self.update_response
29 33 });
30 34 }
31 35
32 36 this.update_response = function(data, textStatus, jqXHR){
  37 + //console.log("starting update_response");
33 38 $.each(data,function(key,value){
34 39 $("#"+key).replaceWith(value);
35 40 });
1  spec/dummy/config/application.rb
@@ -41,5 +41,6 @@ class Application < Rails::Application
41 41
42 42 # Configure sensitive parameters which will be filtered from the log file.
43 43 config.filter_parameters += [:password]
  44 + config.allow_concurrency=true
44 45 end
45 46 end
2  spec/dummy/script/rails
... ... @@ -1,4 +1,4 @@
1   -#!/usr/bin/env ruby1.8
  1 +#!/usr/bin/env ruby
2 2 # This command will automatically be run when you run "rails" with Rails 3 gems installed from the root of your application.
3 3
4 4 APP_PATH = File.expand_path('../../config/application', __FILE__)

0 comments on commit 360213d

Please sign in to comment.
Something went wrong with that request. Please try again.