Expects plugin for HTTP request and response assertions
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
requests_expects
tests
.gitignore
.travis.yml
CHANGES.rst
LICENSE
MANIFEST.in
README.rst
requirements-devel.txt
requirements.txt
setup.cfg
setup.py

README.rst

Requests Expects

https://secure.travis-ci.org/jaimegildesagredo/requests-expects.png?branch=master

Requests-expects is an Expects plugin for HTTP request and response assertions.

Installation

You can install the last stable release of Requests-expects from PyPI using pip or easy_install.

$ pip install requests-expects

Also you can install the latest sources from Github.

$ pip install -e git+git://github.com/jaimegildesagredo/requests-expects.git#egg=requests-expects

Tests

To run the test suite you should install the development requirements and then run nosetests.

$ pip install -r requirements-devel.txt
$ nosetests

License

The Requests-expects plugin is released under the Apache2 license.