Skip to content
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
src/prevayler
Glossary.html
License.txt
ObjectPrevalence.htm
Readme.txt

Readme.txt

Requirements
================
Prevayler requires Java 1.2 or greater.
The GUI for Prevayler's demo application requires Java 1.3 or greater.

This version of Prevayler was tested using JDK1.3.1_01.


Build Procedure
===================
To build and run Prevayler you compile the source code directly. This ensures maximum JDK compatibility.


Demo Application
====================
The prevayler.demo.PrevaylerDemo class is a bank application that uses Prevayler. It has the main() method and can be run directly. It is self explanatory.

Requires Java 1.3 or greater because of the GUI classes used.


More Learning Resources
===========================
1) Javadoc - Included in this distribution.

2) Source Code - Excluding comments and blank lines, Prevayler's implementation is less than 350 lines of code.

3) http://www.prevayler.org - Access to all other Prevayler resources.


Contact Information
=======================
If you have any trouble or doubt running Prevayler, please mail us at prevayler-english@lists.sourceforge.net.

Ideas and suggestions on how to simplify the project are welcome too.

Thanks,
The Prevayler Team.
Something went wrong with that request. Please try again.