Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Email signup seems to be broken or missing some setup #2

Closed
s4mur4i opened this issue Sep 15, 2018 · 2 comments
Closed

Email signup seems to be broken or missing some setup #2

s4mur4i opened this issue Sep 15, 2018 · 2 comments

Comments

@s4mur4i
Copy link

s4mur4i commented Sep 15, 2018

Hello,

I deployed your website for testing, and when configuring and enabling email signup nothing happens.
request
I attached a screenshot of the request I see in developer tools
On netlify console I don't see any new requests comming in.
In app.js logs on netlify console I also see no lines.
Is there some change or setup needed that I missed?

Thank you

@BRS999
Copy link

BRS999 commented Jan 15, 2019

I've figured it out!.

You need to update your code here:

async processForm() { try { const sendgrid = await this.$axios.post( "YOURDOMAIN/.netlify/functions/app", this.emaildata ); console.log("Processed!"); this.sent = true; } catch (e) { console.log(e); }

Just add your domain to the string instead of /.netlify/functions/app.

@jake-101
Copy link
Owner

Hi I've added a env variable called API_URL to netlify.toml that will be in the next release. I never really tested the lambdas locally, I always would publish it to Netlify. Thanks for figuring this out!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

3 participants