New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot paste into SQL window #244

Closed
MrHen opened this Issue Jul 26, 2016 · 9 comments

Comments

Projects
None yet
6 participants
@MrHen

MrHen commented Jul 26, 2016

I am unable to paste into the SQL window/pane. I have tried Command-V, Ctrl-V, using the menu and using the context menu.

I am running Mac OS X 10.11.4 (15E65) and Postico 1.0.8 (1442).

I downloaded the application from this link: https://eggerapps.at/postico/


Specific repro steps:

  • Open Postico
  • Start new connection to a database
  • Double-click on the SQL Query option
  • Inside of the SQL Query pane, try to paste
@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Jul 27, 2016

Owner

Pasting works fine for me.

  1. The keyboard shortcut for pasting is Cmd-V, like all other Mac apps.
  2. Does the window look similar to the screen shot below? If not, can you send a screenshot?
  3. Did you make sure the text area is active (blinking insertion mark)?
  4. Could you double check if there is actually something in your clipboard?
  5. Postico can only paste text. Try copying something from Text Edit. Maybe the app you are copying from uses a non-standard format.

screen shot 2016-07-27 at 17 16 28

Owner

jakob commented Jul 27, 2016

Pasting works fine for me.

  1. The keyboard shortcut for pasting is Cmd-V, like all other Mac apps.
  2. Does the window look similar to the screen shot below? If not, can you send a screenshot?
  3. Did you make sure the text area is active (blinking insertion mark)?
  4. Could you double check if there is actually something in your clipboard?
  5. Postico can only paste text. Try copying something from Text Edit. Maybe the app you are copying from uses a non-standard format.

screen shot 2016-07-27 at 17 16 28

@MrHen

This comment has been minimized.

Show comment
Hide comment
@MrHen

MrHen Jul 28, 2016

Yes, sorry, I meant Cmd-V. I updated the issue.

I attached a screenshot of the window I see. It looks like yours.

  • I cannot paste from Text Edit either
  • If I copy from Postico, I still cannot paste into Postico
  • The only other person I know who uses Postico does not have this issue. It has never pasted correctly for me.

screen shot 2016-07-28 at 9 46 52 am

MrHen commented Jul 28, 2016

Yes, sorry, I meant Cmd-V. I updated the issue.

I attached a screenshot of the window I see. It looks like yours.

  • I cannot paste from Text Edit either
  • If I copy from Postico, I still cannot paste into Postico
  • The only other person I know who uses Postico does not have this issue. It has never pasted correctly for me.

screen shot 2016-07-28 at 9 46 52 am

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Jul 29, 2016

Owner

OK, I'm stumped. Could you open Console.app and see if any error message are written when you try to paste?

Do any other apps on your system have the same issue?

Could you try disabling white-space sanitation? Maybe that causes the issue? Type the following in Terminal, then quit & restart Postico:

defaults write at.eggerapps.Postico SanitizeWhitespace 0

(if that wasn't the cause, execute the command again, replacing 0 with 1 to reenable whitespace sanitation)

Owner

jakob commented Jul 29, 2016

OK, I'm stumped. Could you open Console.app and see if any error message are written when you try to paste?

Do any other apps on your system have the same issue?

Could you try disabling white-space sanitation? Maybe that causes the issue? Type the following in Terminal, then quit & restart Postico:

defaults write at.eggerapps.Postico SanitizeWhitespace 0

(if that wasn't the cause, execute the command again, replacing 0 with 1 to reenable whitespace sanitation)

@MrHen

This comment has been minimized.

Show comment
Hide comment
@MrHen

MrHen Aug 1, 2016

Console has this output:

8/1/16 9:21:20.161 AM Postico[34939]: Can't allocate a new block for a pasteboard. Creation of a new Pasteboard will fail.

However, I also see that message when pasting into Chrome and the paste still works.


Disabling whitespace sanitation did fix the problem! It also removed the Console symptom: pasting no longer causes the "Can't allocate a new block" error.

I will use this workaround for now; if you have anything else you want me to try, let me know.

MrHen commented Aug 1, 2016

Console has this output:

8/1/16 9:21:20.161 AM Postico[34939]: Can't allocate a new block for a pasteboard. Creation of a new Pasteboard will fail.

However, I also see that message when pasting into Chrome and the paste still works.


Disabling whitespace sanitation did fix the problem! It also removed the Console symptom: pasting no longer causes the "Can't allocate a new block" error.

I will use this workaround for now; if you have anything else you want me to try, let me know.

@ghecho

This comment has been minimized.

Show comment
Hide comment
@ghecho

ghecho Aug 28, 2016

I was having the exact same problem in version 1.0.9, The console showed the same message and the "disabling white-space sanitation" command worked, now I can paste into the editor.

ghecho commented Aug 28, 2016

I was having the exact same problem in version 1.0.9, The console showed the same message and the "disabling white-space sanitation" command worked, now I can paste into the editor.

@macarthy

This comment has been minimized.

Show comment
Hide comment
@macarthy

macarthy Jan 11, 2017

"disabling white-space sanitation" + 1

macarthy commented Jan 11, 2017

"disabling white-space sanitation" + 1

@indigoviolet

This comment has been minimized.

Show comment
Hide comment
@indigoviolet

indigoviolet commented Apr 14, 2017

+1

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Apr 19, 2017

Owner

I've now fixed the whitespace sanitation feature in build 1640.

Postico now no longer tries to fix whitespace while pasting, but fixes whitespace automatically when sending the query to the server. Pasting should work again now.

If you've had problems pasting into the SQL Query before, could you try a recent build from here?
https://eggerapps.at/postico/builds/

Owner

jakob commented Apr 19, 2017

I've now fixed the whitespace sanitation feature in build 1640.

Postico now no longer tries to fix whitespace while pasting, but fixes whitespace automatically when sending the query to the server. Pasting should work again now.

If you've had problems pasting into the SQL Query before, could you try a recent build from here?
https://eggerapps.at/postico/builds/

@jakob jakob closed this May 5, 2017

@zhulinpinyu

This comment has been minimized.

Show comment
Hide comment
@zhulinpinyu

zhulinpinyu commented Aug 2, 2017

Great, Thanks for https://eggerapps.at/postico/builds/ 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment