New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Row not encoded, can't export reports #319

Closed
yascat opened this Issue Jan 30, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@yascat

yascat commented Jan 30, 2017

Hi, I cannot seem to export ANY report from postico due this error message. I have uninstalled and reinstalled and the error still exists. Please can you help.

Thanks,
screenshot 2017-01-30 14 22 15

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Jan 31, 2017

Owner

Usually this happens when you try to export files in MacRoman or ISO Latin 1 encoding, but the data contains characters that are not supported by that encoding. If that is the case, please use UTF-8 instead.

If this error happens with UTF-8, can you try to narrow down the problematic column or row? If you perform a "binary search" you should quickly find out which row/column contains the problematic data (execute the select with only the first half of the columns, then with the second half of the columns, etc., until you find which column is the problem).

Owner

jakob commented Jan 31, 2017

Usually this happens when you try to export files in MacRoman or ISO Latin 1 encoding, but the data contains characters that are not supported by that encoding. If that is the case, please use UTF-8 instead.

If this error happens with UTF-8, can you try to narrow down the problematic column or row? If you perform a "binary search" you should quickly find out which row/column contains the problematic data (execute the select with only the first half of the columns, then with the second half of the columns, etc., until you find which column is the problem).

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Feb 9, 2017

Owner

I've changed the error version displayed so it's clear that you have to use Unicode if this happens.

Prerelease: https://eggerapps-downloads.s3-eu-west-1.amazonaws.com/postico-1578.zip

Owner

jakob commented Feb 9, 2017

I've changed the error version displayed so it's clear that you have to use Unicode if this happens.

Prerelease: https://eggerapps-downloads.s3-eu-west-1.amazonaws.com/postico-1578.zip

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment