New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scrollbar visual glitch #365

Closed
dsego opened this Issue Apr 6, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@dsego

dsego commented Apr 6, 2017

This is really a nitpick. Some even/odd striping is showing in the sidebar when dragging the scrollbar.
Version 1.1.2 (1619)
MacOS 10.12.4

screen shot 2017-04-06 at 4 50 22 pm

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Apr 13, 2017

Owner

Took me a bit to track this one down, but changing the text color to a literal value instead of the default control text color seems to fix it. I still need to test if this breaks anything else, but I hope that it should be fixed in the next release.

Owner

jakob commented Apr 13, 2017

Took me a bit to track this one down, but changing the text color to a literal value instead of the default control text color seems to fix it. I still need to test if this breaks anything else, but I hope that it should be fixed in the next release.

@jakob jakob added this to the v1.1.3 milestone Apr 13, 2017

@jakob

This comment has been minimized.

Show comment
Hide comment
@jakob

jakob Apr 19, 2017

Owner

So changing the text color did not work (caused the same glitch on 10.10).

I managed to fix it by subclassing NSOutlineView and overriding allowsVibrancy to return true. This now works on both macOS 10.10 and 10.12.

You can download build 1641 or later; it should be fixed now.
https://eggerapps.at/postico/builds/

Owner

jakob commented Apr 19, 2017

So changing the text color did not work (caused the same glitch on 10.10).

I managed to fix it by subclassing NSOutlineView and overriding allowsVibrancy to return true. This now works on both macOS 10.10 and 10.12.

You can download build 1641 or later; it should be fixed now.
https://eggerapps.at/postico/builds/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment