Permalink
Browse files

Made argparse required only for Python < 2.7.

Closes #7.
  • Loading branch information...
1 parent 5cd4091 commit 3442a5d037f0bddb1cf4bad55a56dac41b330515 @jakubroztocil committed Mar 1, 2012
Showing with 8 additions and 1 deletion.
  1. +8 −1 setup.py
View
@@ -1,12 +1,19 @@
+import sys
from setuptools import setup
import httpie
+requirements = ['requests>=0.10.4', 'Pygments>=1.4']
+
+if sys.version_info < (2 , 7):
+ requirements.append('argparse>=1.2.1')
+
+
setup(name='httpie',version=httpie.__version__,
description=httpie.__doc__.strip(),
url='https://github.com/jkbr/httpie',
author=httpie.__author__,
license=httpie.__licence__,
packages=['httpie'],
entry_points={'console_scripts': ['http = httpie.httpie:main']},
- install_requires=['requests>=0.10.4', 'Pygments>=1.4', 'argparse>=1.2.1'])
+ install_requires=requirements)

0 comments on commit 3442a5d

Please sign in to comment.