New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Please remove dependency on Servlet 3.0 #283

Closed
bdenton opened this Issue Jan 18, 2016 · 2 comments

Comments

Projects
None yet
2 participants
@bdenton
Collaborator

bdenton commented Jan 18, 2016

I have noticed the following dependencies on Servlet 3.0: ServerConformanceProvider calls ServletRequest.getServletContext(). This appears in all three structures projects

@jamesagnew

This comment has been minimized.

Owner

jamesagnew commented Jan 19, 2016

Is this an issue? Servlet 2.5 is 11 years old now (more than Java 6 even), that's some serious backward compatbilty.

We use several Servlet 3.0 features (annotation servlets and websockets being the main ones), so trying to compile with Servlet 2.5 would be challenging...

@bdenton

This comment has been minimized.

Collaborator

bdenton commented Jan 19, 2016

That is all well and good to embrace the required level of standards to make use of more advanced featured. However, I was hoping that we could keep the core components at a lowest common denominator level.
From a purely selfish viewpoint, our product framework is still based on Jetty v7 which does not yet have servlet 3.0 support. I’m sure I don’t need to tell you what a hassle it is to get “product management” to schedule any sort of technology uplift…

From: James Agnew [mailto:notifications@github.com]
Sent: Monday, January 18, 2016 6:25 PM
To: jamesagnew/hapi-fhir
Cc: Bill Denton
Subject: Re: [hapi-fhir] Please remove dependency on Servlet 3.0 (#283)

Is this an issue? Servlet 2.5 is 11 years old now (more than Java 6 even), that's some serious backward compatbilty.

We use several Servlet 3.0 features (annotation servlets and websockets being the main ones), so trying to compile with Servlet 2.5 would be challenging...


Reply to this email directly or view it on GitHubhttps://github.com//issues/283#issuecomment-172712252.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment