Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

include=* doesn't work properly in the jpa server #79

Closed
wdebeau1 opened this Issue Jan 8, 2015 · 2 comments

Comments

Projects
None yet
2 participants

@wdebeau1 wdebeau1 added the bug label Jan 8, 2015

@jamesagnew

This comment has been minimized.

Copy link
Owner

jamesagnew commented Jan 9, 2015

From a skype chat:

[2015-01-09, 10:51:44 AM] James Agnew: Like allow you to define your method as
[2015-01-09, 10:51:55 AM] James Agnew: @IncludeParam(allow = {Observation.SP_SUBJECT, "*"}) Set theIncludes) {
[2015-01-09, 10:52:14 AM] James Agnew: that constant doesn’t include the “Observation.” but HAPI could easily infer that part

@jamesagnew

This comment has been minimized.

Copy link
Owner

jamesagnew commented Jan 9, 2015

Also from a chat Bill: It would be great if the server could optionally automatically enforce includes by not auto-including things that the client didn't ask for.

Even better (but harder to implement) would be if it could also auto fetch includes from other resource providers if the resource provider code didn't already do so.

(Oops, this is already #77 )

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.