Permalink
Browse files

fix argparse requirement for python < 2.6

  • Loading branch information...
1 parent 0ff01c4 commit 49e2e570d720d27e8537d73f120e2abba25d13f0 James Casbon committed Feb 3, 2012
Showing with 5 additions and 3 deletions.
  1. +5 −3 setup.py
View
@@ -3,11 +3,13 @@
requires = []
-# install ordereddict for python < 2.7
-py_version = sys.version_info
-if py_version.major == 2 and py_version.minor < 7:
+# python 2.6 does not have argparse
+try:
+ import argparse
+except ImportError:
requires.append('argparse')
+
setup(
name='PyVCF',
py_modules=['vcf', 'vcf_filter'],

0 comments on commit 49e2e57

Please sign in to comment.