Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Fix travis build #85

Closed
jamescasbon opened this Issue Jan 16, 2013 · 5 comments

Comments

Projects
None yet
2 participants
Owner

jamescasbon commented Jan 16, 2013

No description provided.

Owner

jamescasbon commented Jan 17, 2013

Better... https://travis-ci.org/jamescasbon/PyVCF/builds/4206225

All tests pass, but we get

Done. Build script exited with: 1
Collaborator

martijnvermaat commented Jan 17, 2013

I have no idea, perhaps it was a timeout? Seems unlikely since the tests still completed...

Just as a test, I tried to use nose instead of setup.py test. Fixes 2.6, but breaks 3.2, in #86 .

Do you have any other ideas as to what's going on? And is there a way to manually trigger a new run on Travis? Perhaps it was just a temporary glitch in the system...

By the way, it is quite annoying that you can't attach a branch to an existing issue (or merge an issue with a pull request).

Collaborator

martijnvermaat commented Jan 29, 2013

This post gives some info on how to setup a local Travis VM for debugging. I'll try it later if nobody beats me to it.

Collaborator

martijnvermaat commented Mar 16, 2013

This seems to have solved itself since currently everything passes (example).

Owner

jamescasbon commented Mar 17, 2013

Excellent.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment