Permalink
Browse files

Update core docs

  • Loading branch information...
1 parent 6518978 commit 70bb7b2f687530a593785ae3ceba0984175de735 @jamesu committed Sep 18, 2011
Showing with 5 additions and 50 deletions.
  1. +3 −14 INSTALL.markdown
  2. +0 −24 README.markdown
  3. +2 −12 UPGRADE.markdown
View
17 INSTALL.markdown
@@ -7,20 +7,9 @@ especially if you are not planning on deploying using Phusion Passenger.
## Requirements
-Along with a working installation of the Ruby on Rails Framework, you will need the
-following to deploy & run RailsCollab:
+To install all required gems, simply run the following:
-* *iCalendar* - `sudo gem install icalendar`
-* *RedCloth* - `sudo gem install RedCloth`
-* *ruby-openid* - `gem install ruby-openid`
-* *ActionMailer* - `gem install actionmailer`
-* *Ferret* - `gem install ferret`
-* *Rspec* - `gem install rspec`
-
-Plus the following which are *optional*:
-
-* *Phusion Passenger* - http://www.modrails.com/ (for easy deployment)
-* *ImageMagick* - for generating thumbnails
+ bundle install
## Config files
@@ -83,4 +72,4 @@ The snippit:
script/setup
-For more advanced deployment (e.g. using FastCGI or load balancing proxies), refer to the Ruby on Rails documentation.
+For more advanced deployment, refer to the Ruby on Rails documentation.
View
24 README.markdown
@@ -38,30 +38,6 @@ Check out the [wiki on github] [2].
Please refer to the project entry on [OpenSourceRails] [5] for any screenshots or demos.
-## Can I run RailsCollab on Heroku?
-
-Yes you can! And this is how:
-
-1. Run setup script
-
- script/setup
-
-2. Setup heroku app
-
- heroku create
-
-3. Push database onto heroku
-
- heroku db:push
-
-4. Push config onto heroku
-
- rake heroku:config --app [heroku app name]
-
-5. Launch in browser
-
- heroku open
-
## Licensing
For licensing details, refer to the [LICENSE] [6] file in the root directory.
View
14 UPGRADE.markdown
@@ -1,11 +1,4 @@
-# Installing RailsCollab
-
-Firstly, a word of warning. You will need a command prompt or terminal open in order to upgrade RailsCollab.
-
-It would also be advisable to get yourself up to scratch with the finer details of Ruby on Rails deployment
-if you are planning on upgrading from ActiveCollab.
-
-## From previous versions of RailsCollab
+# Upgrading from a previous version of RailsCollab
The first thing you should do is migrate the database schema to ensure RailsCollab's models
continue to function. This can be achieved by running the following command:
@@ -17,7 +10,4 @@ been added. This can be accomplished by running the following commands:
rake db:railscollab:reload_config
-If you are updating from version 0.8 beta or lower, please note that Forms have been removed.
-
-If you are updating from alpha 2 and below, note that the preferred method for updating configuration
-options is now from the administration interface.
+Thats it!

0 comments on commit 70bb7b2

Please sign in to comment.