Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 29 lines (26 sloc) 1.188 kb
b657568 janfri Use rim/tire.
authored
1 require 'rim/tire'
2 require 'rim/version'
b9ddebc janfri Using regtest for integration testing.
authored
3 require 'regtest/task'
213a10f janfri Switching to echoe.
authored
4
2169ffd janfri Switching to rim.
authored
5 $:.unshift 'lib'
6 require 'mini_exiftool'
7
8 Rim.setup do |p|
9 p.name = 'mini_exiftool'
10 p.version = MiniExiftool::VERSION
11 p.authors = 'Jan Friedrich'
213a10f janfri Switching to echoe.
authored
12 p.email = 'janfri26@gmail.com'
13 p.summary = 'This library is wrapper for the Exiftool command-line application (http://www.sno.phy.queensu.ca/~phil/exiftool).'
2169ffd janfri Switching to rim.
authored
14 p.homepage = 'http://gitorious.org/mini_exiftool'
b657568 janfri Use rim/tire.
authored
15 p.license = 'LPGLv2'
540f934 janfri Prepare release 2.3.0.
authored
16 p.gem_files << 'Tutorial.rdoc'
213a10f janfri Switching to echoe.
authored
17 p.install_message = %q{
18 +-----------------------------------------------------------------------+
0087d59 janfri Preparing release 2.0.0.
authored
19 | Please ensure you have installed exiftool at least version 7.65 |
20 | and it's found in your PATH (Try "exiftool -ver" on your commandline).|
21 | For more details see |
213a10f janfri Switching to echoe.
authored
22 | http://www.sno.phy.queensu.ca/~phil/exiftool/install.html |
0087d59 janfri Preparing release 2.0.0.
authored
23 | You need also Ruby 1.9 or higher. |
24 | If you need support for Ruby 1.8 or exiftool prior 7.65 install |
25 | mini_exiftool version < 2.0.0. |
213a10f janfri Switching to echoe.
authored
26 +-----------------------------------------------------------------------+
27 }
c785e6b Rdoc an Version added
Jan Friedrich authored
28 end
Something went wrong with that request. Please try again.