Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

fix spec

  • Loading branch information...
commit 0f077e75a5836c765ae3f62ba5445a2ce5fa4c09 1 parent 6cdcf46
@janlelis authored
View
2  Gemfile.lock
@@ -8,6 +8,7 @@ GEM
specs:
coderay (1.0.5)
diff-lcs (1.1.3)
+ rake (0.9.2.2)
rspec (2.8.0)
rspec-core (~> 2.8.0)
rspec-expectations (~> 2.8.0)
@@ -22,5 +23,6 @@ PLATFORMS
DEPENDENCIES
coderay
+ rake
rspec
zucker!
View
1  desc/case.yaml
@@ -6,5 +6,4 @@ case:
String#to_snake: "'WasCamelString' # => 'was_camel_string'"
versions:
- 1.9
- - 1.8
View
2  lib/zucker.rb
@@ -16,7 +16,7 @@ module Zucker
:debug => %w|binding cc dd mm oo qq regexp_visualize|,
}
- NON_1_8_CUBES = %w|not|
+ NON_1_8_CUBES = %w|not case|
class << self
# Zucker require helpers
View
18 spec/case_spec.rb
@@ -1,13 +1,15 @@
-require 'zucker/case'
+if defined? BasicObject # 1.9 only
+ require 'zucker/case'
-describe 'String#to_camel' do
- it 'should turn a snake_cased string to CamelCase' do
- 'was_snake_case'.to_camel.should == 'WasSnakeCase'
+ describe 'String#to_camel' do
+ it 'should turn a snake_cased string to CamelCase' do
+ 'was_snake_case'.to_camel.should == 'WasSnakeCase'
+ end
end
-end
-describe 'String#to_snake' do
- it 'should turn a CamelCased string to snake_case' do
- 'WasCamelCase'.to_snake.should == 'was_camel_case'
+ describe 'String#to_snake' do
+ it 'should turn a CamelCased string to snake_case' do
+ 'WasCamelCase'.to_snake.should == 'was_camel_case'
+ end
end
end
View
2  spec/not_spec.rb
@@ -1,5 +1,4 @@
if defined? BasicObject # 1.9 only
-
require 'zucker/not'
describe 'Object#not' do
@@ -8,5 +7,4 @@
nil.not.nil?.should == false
end
end
-
end
View
2  spec/ruby_version_spec.rb
@@ -1,4 +1,4 @@
-require 'zucker/version'
+require 'zucker/ruby_version'
require 'date'
describe 'RubyVersion' do
View
1  zucker.gemspec
@@ -15,6 +15,7 @@ Adds a lot of little helpers that you do not want to miss again."
s.require_paths = ["lib"]
s.required_ruby_version = '>= 1.8.7' # 1.9 recommended
s.license = 'MIT'
+ s.add_development_dependency 'rake'
s.add_development_dependency 'rspec'
s.add_development_dependency 'coderay'
Please sign in to comment.
Something went wrong with that request. Please try again.