Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Fixing protocol-buffer dependencies #5

Closed
wants to merge 1 commit into from

2 participants

@wmoss

Fixing dependencies, these packages don't work with protocol-buffers >= 2

@nkpart

This can be fixed for the current version by applying this patch. However, it looks to me like supporting 2.0.x is just a matter of dropping all mergeEmpty references. I've done this locally, and it works for my very simple interaction with riak.

@nkpart

The dependencies have been fixed in the repo, but riak-protobuf hasn't had an upload to cabal since. Needs a version bump and upload before it'll work for everyone.

@wmoss

Sounds good to me, I was just looking for a fix to get it compiling. Obviously the ideal long-term solution is to have it compile with newer versions.

@wmoss wmoss closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 13, 2011
This page is out of date. Refresh to see the latest.
Showing with 4 additions and 3 deletions.
  1. +2 −2 protobuf/riak-protobuf.cabal
  2. +2 −1  riak.cabal
View
4 protobuf/riak-protobuf.cabal
@@ -58,8 +58,8 @@ library
build-depends:
base == 4.*,
parsec >= 3,
- protocol-buffers >= 1.8.0,
- protocol-buffers-descriptor >= 1.8.1
+ protocol-buffers >= 1.8.0 && < 2.0.0,
+ protocol-buffers-descriptor >= 1.8.1 && < 2.0.0
ghc-options: -Wall -fno-warn-orphans
View
3  riak.cabal
@@ -88,7 +88,8 @@ library
containers,
network >= 2.3,
resource-pool >= 0.1.0.2,
- protocol-buffers >= 1.8.0,
+ protocol-buffers >= 1.8.0 && <= 2.0.0,
+ protocol-buffers-descriptor >= 1.8.1 && < 2.0.0,
pureMD5,
random,
riak-protobuf >= 0.14.0.0,
Something went wrong with that request. Please try again.